Jeep Commander Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
527 Posts
Discussion Starter #1
Hey guys, long time. My Commander is still going strong, just did my 85K mile service, figured I'd give an update and disappear for another years. ;-)

Very few mechanical issues since I bought my Commander with just 7 miles on the clock in 2006 (took it for a 40 mile test drive, deciding between that and a 2004 GC with the Freedom package and diddnt look back)

I replaced the HVAC controls due to lights burned out in 08, had the Cats replaced from recall in 2010, and then from what I think was caused by the cat swap, had to replace to exhaust manifold studs in 2011. Other than that, just brakes, battery, tires and normal fluids, etc..... The trans does delay engagement if I start and immediately put in gear (so I let it idle for 30 seconds after I start) and I get the occasional 'service 4WD system light occasionally but only when I feather the gas when going down a light hill on teh highway and have been driving for 3+ hours over 80. Strange....

But here is the big news, I have always heard of people looking for and not finding the PCV valve. At 85K I figured it was time to get serious about changing it. So I went to the dealer, bought the correct one, and when the resonator box was off for the plug change, did a full on search for a similar looking part and found it. On the 2006 4.7 motor, it screws directly into the intake manifold just a little behind the rear spark plug/injector, and has a large 90 degree large vacuum line. EASY to miss. The old one seemed to sound/work just as the new, but I was starting to get a little hunting and surging at idle and on road so I figured I would change it.

I also changed the plugs, recharged the K&N (every 50K) sea-foamed the intake track of the motor, reset the computer, and dielectric greased all the under-hood connectors.

A Happy camper am I, consistently get 19-20 on the highway if I keep it at about 70, and everything looks and works great. Still love it as much today as I did when I bought it. One of those days, I am going to install the lift kit I've had for 5 years....... I've done all the services, including axle and trans cases, but HAVENT done the antifreeze yet. It all looks and smells good, and that Mercedes stuff is lifetime right?
 

·
Super Moderator
Joined
·
14,964 Posts
There was a catalytic converter recall ? Got any details, link ?
 

·
Registered
Joined
·
527 Posts
Discussion Starter #4
There was a catalytic converter recall ? Got any details, link ?
Beats me, was 2 years ago, when it was in for my water problem, they told me that there was a recall on the cat assembly, and was on backorder, would call when it was in. Thats all I remember.
 

·
Registered
Joined
·
244 Posts
@Jeep5253. I just send a email to a friend of mine that works at a jeep dealer. Once I hear something I will let u know.

Steve.
 

·
Super Moderator
Joined
·
14,964 Posts
@Jeep5253. I just send a email to a friend of mine that works at a jeep dealer. Once I hear something I will let u know.

Steve.
Any word from your friend yet ?
 

·
Registered
Joined
·
405 Posts
I also have a question Bulldog9 how did you use the sea foame on the intake track can you give me a brief description of what you did or if anyone else had done this I would appreciate a step by step or if you know of a youtube video let me know. thank you.
 
1 - 7 of 7 Posts
Top