Jeep Commander Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
2,405 Posts
Discussion Starter · #1 ·
I searched and couldn't find a thread on this. There is probably one out there...not a good searcher.

Anyway, this just started to happen, when I turn the fan control to the big O, for OFF, it continues to blow. It also seems to be blowing higher than it used to when I turn it down low.

Any clues?
 

·
Administrator
Joined
·
16,153 Posts

·
Registered
Joined
·
2,405 Posts
Discussion Starter · #3 ·
Thanks Jeep5253, I saw that thread and that reminded me to post my question. My problem is different but maybe the solution is the same.

I have the dual controls with separate left/right temperature controls, also has selectable manual or automatic mode.
I ran an errand since my first post, and the conditions are these:

1. With the A/C on in manual mode, after I turn the fan from on to off, the fan will blow in high setting with no A/C.

2. The fan speed settings no longer vary the speed. The fan seems to be blowing in a medium range regardless of setting on very low/medium/high or any of the variations in between. However, the A/C does work in all fan settings from very low to high, but in a constant fan speed.

I have not checked the operation in heat or vent modes.
 

·
Registered
Joined
·
2,405 Posts
Discussion Starter · #5 ·
Thanks Robby, where is the relay located? Behind the dash or with the fuses?
 

·
Administrator
Joined
·
16,153 Posts

·
Registered
Joined
·
2,405 Posts
Discussion Starter · #7 ·
Thank you, Thank you, Jeep5253. I'll take the glove box door off tomorrow.
 

·
Registered
Joined
·
213 Posts
GP there is (2) different resistor models. I'm assuming that since you have the dual control it is probably different than the pictures.
When I purchased mine I was happy to hear I had the cheaper one.
I think the other or the one you need may be $150.00.

In the power distribution center (under the hood) there is a mini relay, cavity 39 marked HVAC blower relay. The trouble could be here as well.
In my post with the pictures I called the picture a blower control relay, it is really a blower control resistor.
I think I clarified that in one of the posts but I need to go back and edit that out.
Good luck!
 

·
Registered
Joined
·
2,405 Posts
Discussion Starter · #9 ·
Thanks ScorpionCrawler. I'll check it out under the hood first...easier. I'll post back what I find out.
 

·
Registered
Joined
·
2,405 Posts
Discussion Starter · #10 ·
Two months ago I posted that my blower fan on my A/C would not shut off when I turned it off. Same problem in heat mode.

I finally took my Commander into the dealership. It was not a relay. It was an internal short in the blower fan power module, in the dash, part nbr 5179985AA. Part cost was $78.

Glad to have it quiet in the cab again. 70,000 miles and this was the first expense I've had other than normal maintenance.
 

·
Registered
Joined
·
43 Posts
HELP heater blower fan & A/c

ok over summer a/c would not run if the car was hot like sitting in sun . once i got moving the a/c started ??

heater blower fan.
1-how hard to install myself? anyone with a manual and can send copy of those pages to install?

2- went to dealer cuz there was no heat at all not even any fan. dealer said its the heater blower fan. if i replace that will it fix a/c problem?
the dealer said not under coverage of the 8,80 and its gonna cost $492 +tax for it. found similar on fleabay for $55
 

·
Registered
Joined
·
1 Posts
Heat and A/C problem

When I turn my heater to the off position, hot air continues to come out of the vents. It seems like the faster I go, the harder it comes out. I don't actually here the fan blowing, but can feel the air coming out. I have the same problem with the AC. I took it to the dealership today and was told this is normal operation for jeeps. Obviously, since it hasn't been doing it until recently (or in my 2 previously owned jeeps), this is not normal operation for the car. So before I take it to another dealer, I was wondering if anybody has experienced the same issue or may know what the cause could be? Thanks for the help.
 

·
Registered
Joined
·
43 Posts
well thanks for the help//??? i figured it out my self. cant belive that many people looked at my post and no help. so no one has any manual out there?
i finally found out where the part was and took out n tested it n its no good.
ordered same part on ebay for only$55 shipped saved $450 from what the dealer would have charged
well thanks anyway
 

·
Registered
Joined
·
2,788 Posts
Glad you were able to fix it yourself and save some money. I don't think that there's many of us with manuals. I don't have one...
 

·
Registered
Joined
·
1,096 Posts
This is also the first I've heard of a heater motor needing to be replaced. Sorry you received no help on this, I'm sure if someone here could have , he would have.
 

·
Registered
Joined
·
1 Posts
I currently am trying to solve the same problem -- I can't get the blower to turn off. I turn the dial to off and it seems to even blow more/higher. This is not normal - cause this is the first week that this has been happening to me.
 

·
Registered
Joined
·
862 Posts
There's a couple threads on this. Seems the switch croaks, and ''off'' just ends up putting the blower on high instead. There's a resistor pack for the lower blower motor speeds, with high position bypassing the resistors. Something must fail fairly often, and 'off' just shorts out putting full power back to the blower motor.

Should be a simple dealer warranty issue.

If the fan isn't blowing, then maybe it's stuck on outside vent mode. Driving faster just forces more air in. All the air passages are vacuum controlled, and if things don't move, (i.e. go from defrost to floor etc.) then it's also a dealer warranty issue.
 

·
Registered
Joined
·
43 Posts
under pass side dash board u have to take the panel off. under glove box.
it is 2 screws. remove it
now look under and you will see the blower its a round part. there are 3 screws holding it in.
take out of dash and lay on floor. now hold it and turn on air (turn on low)
make sure you hold the motor cuz it will spin if its good. if it does not spin its a bad motor.
if its bad goto ebay and look up am-autosports and they will have the heater blower motor. i paid $55.95 shipped
or you can go directly to there site at
www.am-autoparts.com
item number hcx-00222
hope that helps
 
1 - 20 of 30 Posts
Top