Jeep Commander Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey everybody...I have a bit of a head scratcher. I have a 2006 Hemi XK with ~50k miles on it. Since the summer really got into full swing, my A/C has been acting up: takes forever to begin blowing cold and only blows cold when moving, the passenger side is blowing 10 degrees warmer than the driver's. Rear is similar to passenger temps. How long it takes to cool off the driver's side is really dependent on the ambient (inside and outside) temperature, which makes sense, but not a good thing. I have taken it to 2 different service shops; the first said pressure was good, but didn't want to take it apart to check for leaks and suggested the dealer for any services. I just got it back from the dealer today after a couple of days of them searching for leaks. They added a little bit of freon to get the pressure to be perfect, but could find any leaks or mechanical issues in the A/C system. My evaporator is free from debris, and if no leaks and no major issues with the condensor, shouldn't I have cold air?
 

·
Registered
Joined
·
405 Posts
I don't know if this might help but my a/c also started feeling like it would only blow colder air wile driving and just regular air while idling, and it just has 40000 miles. What i did is buy a bottle of freon with a pressure tester and added some to the compressor the bottle also says that it includes leak repair so I figured might as well give it a try this was two days ago and my wife hasn't complained yet so might want to give it a try.
 
1 - 2 of 2 Posts
Top