Jeep Commander Forum banner
1 - 5 of 5 Posts

·
Registered
2009 jeep commander 4x4, 3.7v6
Joined
·
5 Posts
Discussion Starter · #1 ·
My ac started blowing warm in the front, compressor was running and line was frosted over. I checked the rear ac in the 3rd row seating and it was blowing cold, but front is still warmer on both sides, manual controls

162638798663275622492070742803.jpg
 

·
Registered
2006 5.7 4x4 Limited
Joined
·
33 Posts
Return the right knob up to "Recirculate within cabin" mode. Still the same?

A 2002 Grand Cherokee (without rear a/c) flaked on me while driving 200 miles. I tried EVERYTHING to get it to blow cold, nothing worked. With fan on high, I rotated the knob to "defrost", and when I did that, several big chunks of foam blew out the windshield vent, and everything worked fine after that. I was 20 miles from my destination.
 

·
Registered
2009 jeep commander 4x4, 3.7v6
Joined
·
5 Posts
Discussion Starter · #3 ·
Same, no change, hot gets hot on all, defrost, heat, air, but when change back to cold its warm on all settings, thinking blend door broke or stuck or maybe actuater broke
 

·
Registered
2006 5.7 4x4 Limited
Joined
·
33 Posts
I wish there was a way to "Back flow" the fan to reverse the pressure and see if blend door would self-correct
 

·
Registered
2009 jeep commander 4x4, 3.7v6
Joined
·
5 Posts
Discussion Starter · #5 ·
I wish there was a way to "Back flow" the fan to reverse the pressure and see if blend door would self-correct
Maybe I will try blowing air in the vents with an air nozzle from my air compressor
 
1 - 5 of 5 Posts
Top