Jeep Commander Forum banner
1 - 17 of 17 Posts

· Registered
2008 Jeep Commander Sport 3.7L V6
Joined
·
15 Posts
Discussion Starter · #1 ·
I have looked at many forums and cannot find a solution for this annoying airbag light. I have tried wiggling both yellow connectors on both seats, I replaced the airbag fuses, it says there is 0 codes. I am hesitant to take it to the dealer. Has anyone solved this? Should I try autozone’s code reader?
 

· Registered
Joined
·
236 Posts
There are special error codes for the airbag system. Not all code readers will read the codes when you get an airbag light. If you can find one of these code readers that will read the airbag code it will tell you what is causing the problem. In many cases it is the clock spring contacts inside the steering wheel under the airbag that causes problems. It is not difficult to fix.
 

· Registered
Joined
·
190 Posts
When my airbag light came on I was able to use the "OBD JSCAN" app on my Android with a $25 bluetooth OBDII reader I got on Amazon. Code was B1B70: up-front left satellite acceleration sensor. Bought a replacement on eBay, swapped it out and the light went away. Definitely try scanning with a reader you know will grab airbag codes.
 

· Administrator
Joined
·
15,451 Posts

· Registered
Joined
·
190 Posts

· Registered
Joined
·
190 Posts
I think the Jscan app will also provide a list of compatible readers. Let us know what you find out.
 

· Registered
Joined
·
16 Posts
Use jcan or AppCatr DiagFca and read values from sensors, they will report plus/minus weights for 4 corners of the seat, adjust the tension using the bolts for each corner of the seat so the sensors will not be off too much and it will solve the issue.
 

· Registered
2008 Jeep Commander Sport 3.7L V6
Joined
·
15 Posts
Discussion Starter · #13 ·
I think the Jscan app will also provide a list of compatible readers. Let us know what you find out.
A year later. 😂 I finally got the code reader and 3 codes came up. Not sure what any of these are.
Font Screenshot Logo Circle Brand
 

· Registered
2008 Jeep Commander Sport 3.7L V6
Joined
·
15 Posts
Discussion Starter · #15 ·
@tankman67 I cleaned and checked the plugs under both seats, also checked fuses. 2 of the codes went away so far all I have is Squib 1 Circuit Open so I’m going to change the clock spring and that should fix it.
 

· Registered
2008 Jeep Commander Sport 3.7L V6
Joined
·
15 Posts
Discussion Starter · #16 ·
@tankman67 I cleaned and checked the plugs under both seats, also checked fuses. 2 of the codes went away so far all I have is Squib 1 Circuit Open so I’m going to change the clock spring and that should fix it.
It was the clock spring, changed and now its gone.
 

· Super Moderator
2006 Commander Limited, 5.7 Hemi QD2
Joined
·
2,372 Posts
Thanks for the fix update. :giggle:
 
1 - 17 of 17 Posts
Top