Jeep Commander Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
136 Posts
Discussion Starter #1
So I installed a brake controller with the factory harness plugged in behind the console with the cigar lighter power. I tied into the green wire under the dash.......followed all of the instructions all looked well with power to the unit, etc. Went to hook up the trailer for the 1st time and the brake controller says N C not connected. Is there another fuse or something else I need to do?

Thx
 

·
Administrator
Joined
·
6,233 Posts
So I installed a brake controller with the factory harness plugged in behind the console with the cigar lighter power. I tied into the green wire under the dash.......followed all of the instructions all looked well with power to the unit, etc. Went to hook up the trailer for the 1st time and the brake controller says N C not connected. Is there another fuse or something else I need to do?

Thx
My first question is do you know what is the Green wire under the dash is used for? I'm sure it's probably the hot wire for something - my question is what specifically?

Secondly did you properly ground this brake controller? I didn't see you mention that you grounded it anywhere and I am sure it needs to have a ground connection somewhere to function properly.

Third, I assume the Brake controller comes with it's own in-line fuse holder - and if that's the case, make sure there is a fuse in it.

If there is a fuse in it, I'd replace that fuse before you look any further, just to ensure it didn't come with a bad fuse.
 

·
Premium Member
Joined
·
136 Posts
Discussion Starter #3
Yes on all questions.

The green wire is for the brake controller install. It is present when the XK has the factory towing. I suspect that there is a break in the wire from the 7 way connector. I have installed many brake controllers (including one on the same day on my Cayenne) and have never had an issue. Will be working on it this weekend if the weather is good here.
 

·
Registered
Joined
·
176 Posts
The green wire is for the brake controller install. It is present when the XK has the factory towing. I suspect that there is a break in the wire from the 7 way connector. I have installed many brake controllers (including one on the same day on my Cayenne) and have never had an issue. Will be working on it this weekend if the weather is good here.
Since you have power to the unit and you've tapped into the green wire (which is the brake signal wire, correct?) then it would seem there is a power break somewhere between the 7-pin in the back and the power distribution center up front. I'm not around my manual at the moment but there's at least one fuse and maybe two for the trailer harness - one for the 7-pin and maybe another for the 4-flat connector as well.

Electrical gremlins like this drive me crazy but for me the fix is usually something simple - I over-complicate things. If you have an RV dealership nearby they will connect a unit to the 7-pin in the back and run a diagnostic to tell you which pins may not be functioning. It really helped me when I had an issue with the 7-pin on my Liberty - they helped me find an short in the harness that was due to my aftermarket stereo rubbing through the insulation on the power wire and shorting it out.

Do all your tail lights, stop and turn lights work on the trailer when you hook it up?

Bob
 

·
Premium Member
Joined
·
136 Posts
Discussion Starter #5
Everything works except the controller.

I have multiple trailers with brakes and 3 vehicles with controllers. Couple of beers this weekend and I'll post back :).
 
1 - 5 of 5 Posts
Top