Jeep Commander Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Just a heads up, with all this computer crap on the cars now-a-days (and when it works it works wonderful<G>)...

I bought a Jeep Commander Limited the MDS, February 1. Anytime I drive it over 20 minutes the BAS/ESP light comes on along with the light above the temp guage (a car with squiggly lines behind it).

Callled the dealer, and was told that was the electronic stability program was failing. Not an emergency, but ok to drive a while and see what other problems may crop up and bring it in for service. (what I would have done anyway)

As it turns out, this problem sometimes affects braking. Twice in the 3 weeks I've had the car, I would press the brakes, the Jeeps starts to stop, then my foot goes to the floor without any futher braking action. Take the foot off the brake and try again, and the brakes work fine for 10-15 days.

The first time, I thought that it was my fault, perhaps my foot slipped off the brakes while I was playing with all the gagets. But the second time, got my attention.

Took it in, and the computer was misprogrammed. ESP/BAS failure light had the same source of error (computer) as the brake failure.

They said they corrected it, but on the way home, the ESP/BAS light came back on. It will be back in the shop on Monday.

But the point is, if the ESP/BAS light comes on, keep you hand on the emergency brake.

Other than that, it has been hard getting use to a large Jeep. I've had Jeeps since 1979 (79 CJ-7, 84 CJ-7, and 93 Cherokee), but all previous ones have been much smaller and lighter.

Tom Duerbusch
 

·
Registered
Joined
·
128 Posts
sorry to hear about this bad news on your jc. Ive been problem free so far.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·
Well, an update...

I brought it back to the dealer. They said that the idiot lights (ESP/BAS) and the brake failure were related. The word was that there were some computers that didn't get programmed and they thought that they caught them all.

Well, the next day after I got the car back, just the ESP light (one over the temp guage) came back on. I immediately brought it back to the dealer. They had it for 5 days and chrysler was now envolved. They replaced the computer.

Had it for 10 days now, no futher lights or problems.

Glad my dealer gives free rentals for warrented repairs during the first year<G>.

Tom
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top