Jeep Commander Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Has anybody had trouble reinstalling the IAT (Intake Air Temperature) sensor into a CAI? I installed an AEM Brute CAI and had too much trouble getting that sensor installed in the provided gromet. I must have lost my patience enough and forced it a bit much as the housing around the tip of the sensor broke off. Oops. The jeep still operates, but I occasionally get the check engine light to turn on so I suspect it needs replaced. I spoke to the local dealer today and they told me that I need to buy the whole box with the sensor and that just the sensor was not available. Does anybody know any different?

A tip for installing this sensor.... use a little lubrication!

Thanks for the input.
 

·
Registered
Joined
·
2,789 Posts
I used a little bit of vaselline and pushed hard but carefully. It did take me a while though to get it in after messing with it. Also, it's kind of hard to believe that they just don't sell the sensor. You tried calling another dealer?
 

·
Registered
Joined
·
54 Posts
Discussion Starter #4
Well in my searching with the local dealer and questioning the online help at chryslerpartsdirect.com, it appears that the only way of replacing the IAT sensor for the 5.7 Hemi is to purchase the sensor with the resonator (the big plastic box that gets replaced with a cold air intake). The MSRP is $151.00. This turned out to be a costly mistake for me. I have not replaced it yet, I am still holding out a glimmer of hope.
Does anybody know if there would be a difference between the sensor for the jeep and the sensor for a different Jeep/Chrysler model with the same engine?

Learn from the landminds that others have found.... don't break this sensor!
 
1 - 4 of 4 Posts
Top