Jeep Commander Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Cluck sound on passenger side on turns and put holes.

My jeep is giving clunk sounds on turns and driving to small put holes :(
The clunk sound is hear able and feel able on the passenger side.
I’m not sure if it’s the sway bar or the CV joint on the passenger side.

I looked under the jeep, and see that my sway bar is slightly displaced (moved) to the right-side (not sure if this is normal). Need some advice to rule some things out!

How to tell if the end links are shot? :icon_confused:
How to diagnose if the CV joint is busted? :icon_confused: (There is no grease on the rubber boots or cracks).

I will put some pictures up later, to show the slightly displacement of the sway bar.


 

·
Registered
Joined
·
89 Posts
I'm currently having similar issues with my '07. The source is my upper control arm. Using a long pry bar, I'm able to see way too much movement in the ball joint. I have some Rocky Road replacements on the way now.

After shipping, the pair is around $370. Hopefully, your issue is something simple like sway links. Disconnect them and slowly drive around your neighborhood. If the sound is gone, it's the sway links. If I have to switch one, I switch both. Even if the other side is good, it's probably not far behind the other in failing.
 

·
Registered
Joined
·
405 Posts
I have the same noise comming from my passenger side except it does not happen while turning, sometimes it happens when I put the jeep on reverse I hear a click or clunk and when I go over small potholes it sounds like the tire or something else is rattleing not sure what it can be, I replaced the endlinks, I had already replaced the swaybar bushings and I also had the upper control arm replaced, anyone else has an idea of what it can be I checked everything that I can think of and nothing.Also I had the RC lift installed recently and I believe that is when I started noticing the noise more. :shrug03:
 

·
Registered
Joined
·
405 Posts
I see no replys but alot of views my question now is do any of you viewers have this issue maybe you do but you have not resolved it like me I just want to know if I am one of the few with this issue or if it is a more common issue then I thought?
 

·
Registered
Joined
·
6 Posts
Torque down all the suspension bolts. I have been chasing this clunk on a 2006 CRD Commander for several months, including replacing the sway bar bushes to no avail.

Then one day I decided to check ALL the suspension bolts,mans found one of them loose. Quite a simple fix, in the end.:woot:
 
1 - 5 of 5 Posts
Top