Jeep Commander Forum banner
1 - 3 of 3 Posts

·
Banned
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi guys. Hope you can help me. I have a 2007 CRD and its just great. It has around 105 000 mile on the clock. A couple of months back I had a minor accident and it damaged the steering rack. The insurance had a it replaced but it broke again a couple of months later. After quite a fight it was replaced again. The car was working perfectly other than that. It took them around six weeks to get parts etc. So today I get a call that my car is ready but I need to send a tow truck as it is in limp mode. They are saying its in limp mode due the glow plugs needing replacement, as well as the glow plug control unit and the Sensor MAP. They say that is the cause of it being in limp mode. I am just not convinced and I dont know enough to accept this. Please anyone, can you confirm if this can indeed cause the car to go into limp mode? I am so over these guys and they are saying they wont replace the items as its due to ware and tare. I dont understand how the car was fine a couple of weeks ago and that all three these problems came into play while it was with them. Please help...
 

Attachments

·
Administrator
Joined
·
7,301 Posts
Hi guys. Hope you can help me. I have a 2007 CRD and its just great. It has around 105 000 mile on the clock. A couple of months back I had a minor accident and it damaged the steering rack. The insurance had a it replaced but it broke again a couple of months later. After quite a fight it was replaced again. The car was working perfectly other than that. It took them around six weeks to get parts etc. So today I get a call that my car is ready but I need to send a tow truck as it is in limp mode. They are saying its in limp mode due the glow plugs needing replacement, as well as the glow plug control unit and the Sensor MAP. They say that is the cause of it being in limp mode. I am just not convinced and I dont know enough to accept this. Please anyone, can you confirm if this can indeed cause the car to go into limp mode? I am so over these guys and they are saying they wont replace the items as its due to ware and tare. I dont understand how the car was fine a couple of weeks ago and that all three these problems came into play while it was with them. Please help...
I really know very little about the CRD Commanders (other than they have a 3.0L Diesel Engine) as they are few & far between in the U.S. but this definitely sounds off to me.

If your Commander was running when you brought it there and it's not running now and they are asking you to pick it up with a tow truck I would definitely talk to the shop manager & if you can't get any reasonable solution to tis problem from him or her, call the police and get them involved.

If you are in the U.S. (which I don't know because your profile is incomplete - hint, hint) I'd also get the better business bureau involved.

Also David, please click on the link below, read the announcement and follow the instructions to complete your user profile.

https://www.jeepcommander.com/forums/9-problems-dealer-service/announcements.html
 

·
Registered
Joined
·
236 Posts
Look under the hood for broken wiring looms. Years ago, a friend had this situation with a shop visit as they claimed an ignition module had died while it was in the shop. It was very evident that the wire loom connector had taken a hit from something and snapped off.

You could try the "master reset": disconnect the postive battery lead, and ground it out. Then connect it back.

An accident that damages a steering rack seems more than minor?
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top