Jeep Commander Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello fellow mander lovers, I'm new to this forum and new to the jeep life, especially the mander life. I have a 2006 limited Hemi with quadra drive 2 and all options 161,000 miles. Cold weather came around and my mander started "eating" coolant. I'd fill my reservoir tank and top off the coolant and the next 2 days or so the reservoir box would be empty and the radiator would have no visible coolant inside. However, no exterior leaks (no puddles on the ground, no hoses disconnected/loose) had a professional Chrysler guy look at it and he did a pressure test, found a leak in the water pump. Replaced that, flushed cooling system, replaced the thermostat and serpentine belt (honest guy, doesn't charge crazy like dealers lol). I replaced the PCV valve after I got it back and a week later I popped the hood and dang, no coolant in the reservoir. Yes, my mechanic DID top of the radiator and filled reservoir halfway with HOAT coolant. Also, my oil filler cap has yellow sludgy gunk on it, along with the inside of the radiator as it looks like dirt floating in it. It's not a head gasket, jeep runs perfect and plenty of power, and I can run WEEKS "without" visible coolant on normal operating temp and never overheating since I owned it. What the heck is wrong with my baby? Thanks for any help, just want her healthy. BTW oil dipstick has no sludge or gunk, and when draining oil from the pan, no "water" or "runny" symptoms, Just normal oil coming out, maybe a slight orange tinted layer with bubbles when in my drain pan.

Pls help me, I'm obsessed with this car:(
 

·
Registered
Joined
·
147 Posts
What you are describing is the beginning of a blown head gasket.
You're not going see the water on your dipstick. Because it's submerged down in the bottom of the pan with clean oil. But when it blows, you'll see the oil change color.
You need further testing if you are unsure.
The residue you see is from the steam generated from exhaust gas getting into cooling system.



Sent from my Samsung Galaxy S 10+ using speech to text
 
1 - 2 of 2 Posts
Top