Jeep Commander Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I have a 2006 XK which is starting to have some of the dash lights go dim and go out. I know this is a common thing with the WKs and XKs. I have dual climate control and half of it is more dim then the other. Also I just noticed the driver side heated seat button does not light up anymore. Not a huge issue, but since the rest of the car is in such great shape I would like the interior to seem that way. Is there a way to replace the bulbs or do I need to find a way to get new buttons and climate controls? Thanks
 

·
Registered
Joined
·
143 Posts
I have the very same issue with the buttons on my dash. My 2007 has almost 96k on the odometer and the whole lower row of buttons except for just 1 is out, and on the row above the heater controls same thing...all but 1 out. Fortunately the heater ones are all working. It looks like about 10 are burnt out.

The two links above do show how to replace the bulbs on the heater board, so hopefully the upper row and lower row are just as simple to remove the covers and solder on new bulbs.

I see Radio Shack bulbs are suggested ..Is one prefered over the other?
RadioShack 272-1092 (12V, 60mA, Wire terminal base) OR
RadioShack 272-1154 (12v, 50mA, Bi-Pin lamp)

I also watched a video today where a guy swapped in Eiko 2162 14v .1A/T1-3/4 Wire Term Lamp Light Bulbs. I'm not sure if thats a good way to go or not. I believe they are all .75 watt bulbs

However does anyone know the exact bulb that Jeep used from factory? It would be great to use the exact spec bulb, to ensure the brightness is consistent. Unless that's already figured in with the 2 options suggested in the threads. Its probably worth just doing all of them while its apart. (upper and lower row). I repaired my wide screen computer monitor last year and it wasn't that bad soldering in capacitors. It was a little intimidating at first (I'm not the sharpest knife when it comes to electrical), but overall pretty easy. The hardest part was verifying the exact specs for the repair parts.
 

·
Registered
Joined
·
143 Posts
I ended up picking up a a bunch of bulbs today at Radio Shack.RadioShack 272-1154 (12v, 50mA, Bi-Pin lamp)Upon arrival at the RadioShack...I saw they were going out of business and closing all their local retail stores tomorrow. At least where I live in south east PA.
So after hitting 3 different stores in a 95% blow out frenzy, I managed to get 14 bulbs total for just .17 cents a piece. That's a great deal over about $2.50 each at regular prices. I kinda wanted the 272-1092 (12V, 60mA, Wire terminal base) but they were all gone already.

I now have my dash panel out and it looks like all the factory bulbs have a bluish green varnish over them to produce a greenish light. The Radio Shack bulbs are clear, so I initially wondered if I could coat them with something like a colored sharpee marker or something to make them colored blueish/green vs just clear?

Then I realized that they were just very small rubber boots that slip over the bulbs to give them color. I managed to remove all of them and replace them on my new bulbs. I tore one boot slighty removing it. I realized its better to remove the old bulbs from the square base first, then gently roll the boot off. Its a bugger removing the bulb bases and it took about 10 min to realize how to do it on the first one. After that it was pretty simple, just tedious and time consuming.
It took me a little over 5 hours tonight to replace all the bulbs except for one. The bulb that is positioned under the automatic pedal adjuster was just too much of a pain to remove. First you have to unsolder the switch which sits on top of it. You would have to use a copper wick to remove all the solder on 6 points of contact on the board. I started to do it but then decided maybe I'll do it if any other bulbs go in the future. I haver no reason to move my pedal, especially in the dark so I eliminate about an hour of additional time on the project. Tomorrow I need to reinstall the panel and hope that everything works as it should.
 

·
Registered
Joined
·
2 Posts
Bump... on a similar note i have the illumination going on the Heating/AC and below the radio for some reason. Has anyone been successful finding and changing out the suspect bulbs?
 
1 - 6 of 6 Posts
Top