Jeep Commander Forum banner

1 - 5 of 5 Posts

·
Banned
Joined
·
13 Posts
Discussion Starter #1
Hi before the electric windows, radio etc would work for about 10 mins after ignition was turned of or in till door opened. Now it doesn't and radio lights up when dashboard lights are on but radio will not work or display, time, come on when ignition is on? Regards and thanks.
 

·
Registered
Joined
·
480 Posts
Do you have an aftermarket or stock radio? Do the rest of your electronics work when the ignition is on?
 

·
Registered
Joined
·
84 Posts
I think there is some sort of accessory delay module or relay. Im not sure but it might have its own fuse that could be blown or the module could be bad. If you have the owners manual, check the fuse box for something that sounds like it. Is there a hidden feature in the evic that disables this too? Just throwing ideas out there.
 

·
Registered
Joined
·
15 Posts
A bit late answer but perhaps helpful. See WK/XK fuses here. Check Power Distribution Center fuses and based on the year of your vehicle, it might be fuse 8 (2005-2007) or fuse 18 (2008-2010). Check if this fuse isn't blown.

Then, according to the service manual, there is Run/Accessory Delay relay in Junction Block (where fuses are below steering column). I am not sure where this relay is, since all I can see there is fuses, circuit breakers and connectors (see the fuse list in above link). But this relay might be the second thing broken.

Third, this relay is controlled from Front Control Module. That is a module attached to one of the fuse boxes in the front (looks like this). I am afraid that is a PCB black box and if faulty, you will probably have to replace it.
 

·
Super Moderator
Joined
·
5,763 Posts
A bit late answer but perhaps helpful. See WK/XK fuses here. Check Power Distribution Center fuses and based on the year of your vehicle, it might be fuse 8 (2005-2007) or fuse 18 (2008-2010). Check if this fuse isn't blown.

Then, according to the service manual, there is Run/Accessory Delay relay in Junction Block (where fuses are below steering column). I am not sure where this relay is, since all I can see there is fuses, circuit breakers and connectors (see the fuse list in above link). But this relay might be the second thing broken.

Third, this relay is controlled from Front Control Module. That is a module attached to one of the fuse boxes in the front (looks like this). I am afraid that is a PCB black box and if faulty, you will probably have to replace it.
https://www.jeepcommander.com/forums/10-electronics-nav-discussion/55657-junction-block-explained.html

This is the best post I've seen that gives an excellent breakdown of the junction block and the associated fuses and their functions.
 
1 - 5 of 5 Posts
Top