Jeep Commander Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
I'm new to owning a Commander. I just purchsed a 06 Commander at the weekend, and it has a few gremlins which i'm hoping people can help me sort.

When driving sometimes the ETC (Electronic Throttle Control) light is flashing on the dash, but at the same time it starts flashing there is a whining coming from under the jeep. I thought it was the fuel pump at first in the tank, but i replaced that for a new one and it's still there. The engine management light is also on all the time.

I also have a flat spare tyre and a message on the screen shows its got low pressure all the time. Is it possible to just put a standard valve in the spare or will it show that the spare is then missing?? The valve has been snapped off so i can't re-inflate it.
 

·
Registered
Joined
·
5,610 Posts
hello and welcome. your entire issue could be related to the TPMS.
The system is looking for input and cant find it.

Or it could be a wheel speed sensor.

I'm new to owning a Commander. I just purchsed a 06 Commander at the weekend, and it has a few gremlins which i'm hoping people can help me sort.

When driving sometimes the ETC (Electronic Throttle Control) light is flashing on the dash, but at the same time it starts flashing there is a whining coming from under the jeep. I thought it was the fuel pump at first in the tank, but i replaced that for a new one and it's still there. The engine management light is also on all the time.

I also have a flat spare tyre and a message on the screen shows its got low pressure all the time. Is it possible to just put a standard valve in the spare or will it show that the spare is then missing?? The valve has been snapped off so i can't re-inflate it.
 
1 - 3 of 3 Posts
Top