Jeep Commander Forum banner
1 - 4 of 4 Posts

·
Registered
2007 Jeep Commander (XH) 3.0CRD
Joined
·
14 Posts
Discussion Starter · #1 ·
Hi all, I've read several posts about the above dash lights. Mine came on today and won't go out with the suggested lock-to-lock fixes and all the engine bay fuses are all intact. Clearing all fault codes also doesn't help (I have BlueDriver and JScan). The bizarre thing is that the car is due into the dealers next week for the P73 and P41 recalls - FDCM reflash and steering barrel (mine thinks it has the key in permanently, even when removed!). The P73 was intended to fix the 'Service 4x4 System' light I was getting when I tried to operate low range.

Now I have the three lights, my Low Range has started working!

Anyone have any other things I can try before giving the dealer a blank check?
 

·
Administrator
Joined
·
16,114 Posts
@Bumpydog What codes are you getting? Most likely it is just a bad wheel speed sensor. If you do a forum search you will see threads on this. It is an inexpensive and easy do-it-yourself fix.
 
  • Like
Reactions: dar124

·
Registered
2007 Jeep Commander (XH) 3.0CRD
Joined
·
14 Posts
Discussion Starter · #3 ·
@Bumpydog What codes are you getting? Most likely it is just a bad wheel speed sensor. If you do a forum search you will see threads on this. It is an inexpensive and easy do-it-yourself fix.
Hi, I'm getting C123F Steering Angle Sensor Comparative Performance and U0415 Invalid Data received from Anti-Lock Brake System Control Module 'A' (but I don't have an ABS warning light)

P.S. I've tried disconnecting the battery for 30 mins to no avail. If I clear the codes, they come straight back. My cruise control is still working.
 

·
Administrator
Joined
·
16,114 Posts
Hi, I'm getting C123F Steering Angle Sensor Comparative Performance and U0415 Invalid Data received from Anti-Lock Brake System Control Module 'A' (but I don't have an ABS warning light)

P.S. I've tried disconnecting the battery for 30 mins to no avail. If I clear the codes, they come straight back. My cruise control is still working.
@Bumpydog Google those codes for a Jeep and see what you can figure out.
 
1 - 4 of 4 Posts
Top