Jeep Commander Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
On Thursday after driving to work, i noticed a nice orange puddle under the front of my Jeep. I was in a suit so I couldn't get on the ground, but after some looking around, I saw coolant leaking from the water pump area. Called the local dealer and limped her over to them for a look. On Friday, dealer confirmed they'd ordered a new water pump and the Jeep would be back together by Monday (assuming part comes in Monday morning).

I thought a water pump failure at 46,000 miles seemed a bit soon. I am curious if anyone else has had a water pump fail on the 5.7L motor with less than 50,000 miles on it?:disappointed:
 

·
Premium Member
Joined
·
12,563 Posts
No failure here! 16,000 miles and three years.
 

·
Premium Member
Joined
·
6,309 Posts
I have a 2007 with over 60,000 miles and I'm still on water pump #1.
 

·
Registered
Joined
·
452 Posts
I have a 2007 with over 60,000 miles and I'm still on water pump #1.
I have over 57K on my 2006 HEMI, and still on original water pump as well. Actually, almost everything under the hood is original still, aside from spark plugs and air filters.
 

·
Registered
Joined
·
1 Posts
lost mine on my 2006 v6 a little over 40,000 miles. driving home from a florida vacation. It locked up and burned through the belt after hearing a squealing noise first.Luckily there was a hotel at the nearest exit..I noticed the pulley was very loose and some roller bearings were laying on top of the pump.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #8 (Edited)
Well, I got my Jeep back on Monday and no leaks since then. I popped the hood this morning to check fluid level and the reservoir was empty. Oops! I checked my receipt from the dealer and it shows they added fluid, but I guess it wasn't enough. I'm going to add (Zerex G-05 if I can find it) some and see how the level does. Otherwise, very happy to have my Jeep back. So, to anyone who has work done on the radiator/waterpump - make sure you check your fluid level.:)
 

·
Registered
Joined
·
59 Posts
Discussion Starter #10
I finally found some Zerex G-05 fluid at NAPA Autoparts. Price wasn't too bad either, only about $8.80 for a gallon of 50/50 mix. I was surprised that Autozone, Pep Boys, and O'Reilly's only carry the universal fluids for all manufacturers.
 

·
Registered
Joined
·
40 Posts
After smelling antifreeze, I thought I had a pinhole leak. Since I'm still under extended 80k warranty on my '07, brought it to dealer. They're replacing the water pump. ~34k I think. 4.7Flex.

I'm driving a rented Dodge Caliber now. It sucks.

-Blu
 

·
Registered
Joined
·
106 Posts
Had to replace the h2o pump on mine this spring - about 60k or so
 

·
Registered
Joined
·
27 Posts
replaced mine at about 67k miles. Was driving then all the sudden my engine temp went nuts. I pulled over and coolant was shooting everywhere under the hood.
 

·
Registered
Joined
·
186 Posts

·
Banned
Joined
·
1,406 Posts
06 with 4.7 - purchased new 4 years ago. 46K. Original pump. :eek:rangehat:
 

·
Registered
Joined
·
47 Posts
63K and original pump, previous 5.9 limited used to eat them every 13-18 months...
 

·
Registered
Joined
·
130 Posts
I am on the original pump as far as I know. I bought the Jeep with around 44,000 miles and she now has 68,000. I have been noticing a little bit of a belt noise when starting it up cold but I dont think it is a pump, probably more like a worn out belt. Will be replacing them in the spring I think just to be sure.
 

·
Premium Member
Joined
·
97 Posts
51k on original water pump, had a slight explosion. Coolant went every where. Had it replaced by the dealer under extend warranty.
 
1 - 20 of 20 Posts
Top