Jeep Commander Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
it feels like my 08 jeep commander does not have that go like it use to have. its like i got my foot on the gas and i am not speeding up like it use to. notice it alot going up some hill. also i have a sqeek coming from the driver side wheel can someone help me. thank you
 

·
Moderator
Joined
·
1,993 Posts
it feels like my 08 jeep commander does not have that go like it use to have. its like i got my foot on the gas and i am not speeding up like it use to. notice it alot going up some hill. also i have a sqeek coming from the driver side wheel can someone help me. thank you
Is it a constant noise or intermittent? Is it more like a break squeaking from dust or like the tattletale noise of worn shoes? or a deeper noise? How many miles? Does it feel like the engine is over working like pulling a trailer? If you put in in neutral does slow down rapidly or coast normally? Probably going to need this information for someone to help you out.
 

·
Super Moderator
Joined
·
15,103 Posts

·
Registered
Joined
·
87 Posts
it feels like my 08 jeep commander does not have that go like it use to have. its like i got my foot on the gas and i am not speeding up like it use to. notice it alot going up some hill. also i have a sqeek coming from the driver side wheel can someone help me. thank you
a little more info would be helpful...

which engine?

any aftermarket mods like CAI or exhaust?

has it been a gradual digression or a sudden change?

did it run ok until you made any recent changes?
-mods to the engine?
-change wheels/tires to a size that isn't stock?
-engine tuner/programmer?

how long since you've done any maintenance?
-clean/change air filter?
-spark plugs?
-brake job? (maybe they're dragging)

and this may sound stupid, and i hate to offend, but is the parking brake working properly? i've seen the cables bind up and wouldn't release, cuasing a "loss of power" and strange noises and smells.

and if that doesn't help, you should order an adjustable powerband
 

·
Premium Member
Joined
·
92 Posts
along the same lines of what Doc in AZ said

-oil change?
-diff fluid change?
-air filter change/charge/cleaning?
-spark plugs?

could be a possible carbon build up in the engine as well, I dont know how many miles you have but I drove a dodge that once was so clogged with carbon whenever it stopped it would shut off for lack of O2. i know your problem isn't that serious but it's a possibility.

good luck! let us know what you find.
 

·
Registered
Joined
·
44 Posts
Not wanting to hijack the thread, but the first service I got where the air filter was changed, I immediately noticed a power drop. I, haven't really felt the V8'y goodness since that day. I guess some filter reserach is in order on my part but I thought it might be worth mentioning.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
its a v8 hemi engine and it has 63000 miles.goin to try the brakes first to see it it helps. the power promblem happened since i got the oil changed no change in oil type or brand. feels like i am pulling something.
 

·
Super Moderator
Joined
·
15,103 Posts
its a v8 hemi engine and it has 63000 miles.goin to try the brakes first to see it it helps. the power promblem happened since i got the oil changed no change in oil type or brand. feels like i am pulling something.
bi gal, since this happened since you had the oil changed that could be the problem. The 5.7 HEMI requires 5W20 to operate properly. Unless you changed the oil yourself then the wrong weight oil may have been put in.
 
1 - 9 of 9 Posts
Top