Jeep Commander Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1 (Edited)
So, I bought the 3875 for the speedo calibration (going to run bigger tires) and figured I would try the fuel economy settings since I bought it. I'm currently deployed so my wife programed it because she drives it from time to time. First off when she update the tuner the first time it took forever and didn't work right so she had to do it again. Then she programmed it to the fuel economy to see how it would do and the battery went dead after the program (not blaming it on the tuner at all but it may have something to do with the end result of this story). When she got the Jeep started for a little trip to the zoo she noticed that several lights were displayed in the dash ( Low trac,esp, and a few others maybe. Can't remember). Again, not blaming the tuner but these lights NEVER appeared until after the program. So I told her to program it back to factory settings and take it to the stealership. She went to do this and the tuner said that the VINs didn't match up so now she can't reprogram it to anything if she wanted to. Not to mention that I probably lost my factory settings for my Jeep in the process. So, she called the customer service and after being on hold for a long time and being rude to my wife they gave her a list of things to try and told her it should work.....Wrong!! She did those things and still doesn't work. Called again to be on hold again and for them to say there's something wrong with my ECU. Guess a faulty piece of equipment couldn't be a factor. I don't know. Don't get me wrong I'm not knocking this product, but just sharing my story. For there are a lot of people on this forum who have this tuner and love it and I guess I'm one of the unlucky few. Not saying I don't like it, but it's kind of a let down after wanting one of these for years for my Jeep and I finally get it and run into more problems. So, my wife test drove the Jeep to see if it was ok to drive so she could fit everyone in one vehicle and everything was fine. So, here are the updates.

Before 12-15 MPGs overall After 15-17 MPGs
Also a plus: She said that she noticed it idled A LOT smoother when fist started because before it sounded pretty high and took a little while to settle down

Power: She said it felt like it still had plenty of power (for her)

So, in the end I would still recommend this product if you have the extra money and plan on running bigger tires too. Haven't gotten to play with it myself yet but sharing my wife's experience. I will give updates on how this whole mishap gets handled.
 

·
Premium Member
Joined
·
6,309 Posts
I love my Flashpaq. I've had my 4.7 tuned to 91 Performance for years now with the tire size corrected to 33's and off road setting to disable TPMS sensors. No problems here!
 

·
Registered
Joined
·
7 Posts
I can only say that I used one of these Superchips and had multiple problems and worse than that was the company's customer service. When I relayed the problems, they practically said I was lying (Their programmer wouldn't do anything like that, etc), and said that there was something wrong with my Jeep. There wasn't. It was their inferior chip and most of all their terrible lack of customer service.
 
1 - 3 of 3 Posts
Top