Jeep Commander Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
My front passenger turn signal has not been working for sometime. When I took it to the dealership a year or so ago they confirmed it was a module that needed to be replaced (it is not the obvious bulb or fuse). I can't remember the part name / number but I do remember it costing about $300-400+. Just wondering if any one would know what relay or possible part it would be. Jeep is an 06 Commander 3.7L.

Also when I turn on the running lights the front right bulb lights up and stays on. However when I select the right turn signal only the back right light blinks and the signal blinks faster than normal since only the rear signal is receiving the current.


Thanks for the help
 

·
Super Moderator
Joined
·
5,881 Posts
Also when I turn on the running lights the front right bulb lights up and stays on. However when I select the right turn signal only the back right light blinks and the signal blinks faster than normal since only the rear signal is receiving the current.
Thanks for the help
That's a classic indication of a bulb with a burnt out filament.

When functioning properly, the turn signal on each side of the vehicle, is it's own closed circuit which is made up of the front & rear turn signal. Left side turn signal (front & rear) is one closed circuit, right side turn signal (front & rear) is another closed circuit.

When you have a bulb with a burnt out filament that's not working, the turn signal circuit is now open - which is what causes the working signal bulb to blink faster.

I would replace both bulbs - front passenger turn signal & rear passenger turn signal - but I would replace the front passenger turn signal bulb first and see if that corrects the problem. If it doesn't, then replace the rear passenger turn signal bulb.

It's simple enough to do yourself and it might cost you $10.00 for both bulbs.

I'd be willing to bet you will find your turn signal works just fine, once you replace those 2 bulbs.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Replaced both bulbs just to be sure, still have the same problem. Like I said the dealer narrowed it down to a module that needs to be replaced, just wondering if anyone had this issue or better yet knew the relay / module part number.

Thanks
 
1 - 3 of 3 Posts
Top