Jeep Commander Forum banner

1 - 4 of 4 Posts

·
Banned
Joined
·
159 Posts
Discussion Starter #1
So trying to track down the gremlins in my headunit and came across a question. I noticed in the front fuse box under the hood both my low and high radiator fan relay are missing as well as the fuse for the radiator fan. I know not all fuses and relays are used in every model so I am crowdsourcing some help.

Will someone with a 2008+ with the hemi please check the forward most fuse box under the hood and see if you have these fuses/relays.
 

Attachments

·
Premium Member
Joined
·
655 Posts
The Hemi has a hydraulic fan that runs off the power steering pump. Not electric like the 4.7 or 3.7. Mine looks exactly the same.
 

·
Registered
Joined
·
20 Posts
So trying to track down the gremlins in my headunit and came across a question. I noticed in the front fuse box under the hood both my low and high radiator fan relay are missing as well as the fuse for the radiator fan. I know not all fuses and relays are used in every model so I am crowdsourcing some help.

Will someone with a 2008+ with the hemi please check the forward most fuse box under the hood and see if you have these fuses/relays.


rblapham nailed it. that is why you see the fan running all the time.
 

·
Banned
Joined
·
159 Posts
Discussion Starter #4
The Hemi has a hydraulic fan that runs off the power steering pump. Not electric like the 4.7 or 3.7. Mine looks exactly the same.
Cool, figured it wasn't a big deal since it hasn't been causing issues. Have found a few a few less than satisfactory fixes so just double checking.
 
1 - 4 of 4 Posts
Top