Jeep Commander Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a Jeep Commander. I bought this vehicle a couple of years ago. I added some logos from my favorite football team and did drive it to a couple of football games.
It is the right color (red).
It has a 3rd party radio that whoever installed it didn't know what they were doing. It rumbles everytime you start and drive the vehicle. I am now ear blind to it. I don't hear it anymore.
For the most part this is a decent vehicle. I have replaced the battery recently and done some other maintenance on it.
I am hoping to get some more information from this forum to help me troubleshoot the current issues. If I don't get this resolved I might just have to put it out to pasture and let it go.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
Electrical Grimlins

I have a 2006 Commander that I like for the most part.

2006 Jeep Commander, Hemi 5.7 Ltr engine, DOHC. Not sure which transmission. Sunroof


I had an electrical issue that I drug my heels for awhile. It was not acting right.


About 3 or 4 months ago the Jeep had some issue where it needed to be jumped all of the time. I would jump it and check the battery but it said it was good. But soon or the next day it would need to be jumped again. I finally went to O'Reilly Auto and replaced the battery. It seems to be working much better. At least it runs now with no problems.


I am not sure when the current issue started but it wasn't too long after the battery was replaced.
I know the car was wet inside. When it rains the passenger side would just fill up. I checked the tubes from the sun roof and they aren't clogged and they are in properly.The windshield was cracked and it was replaced in the last month.


When I am driving down the road the lights flash on / off. The interior dash lights just flash and it sounds like it is resetting itself.

I can here something coming from under the hood.

The lights flash, the speedometer and the tachometer just fluctuate in unison.
I have a check engine light on and the air bag light on continuously.
Going through a drive through and the vehicle will go through the motions turning on the headlights, turning on all of the dashboard lights. The radio won't actually come on it just cycles over and over. but that could be the installer who installed a 3rd party radio.
Using the turn signals just is a guess to when it works. It isn't the repetitive sound of a normal turn signal. Neither of them work like they should.


My key fob doesn't work, I have been using a manual lock / unlock since before the battery was replaced.
I replaced the ignition switch and the multi-function arm with the headlights and turn signals and fog lights.


It is not repeatable, I can't do something and know it will happen. It just does it's crazy motions almost none stop.
I know it has to be an electrical issue but I don't know where to begin.


Can someone tell me where to begin. I have a fix'd fob that I can connect and get the engine codes. I have looked at them but they are not specific enough to find the issue.


Thanks
Ron
 

·
Super Moderator
Joined
·
5,845 Posts
I have a Jeep Commander. I bought this vehicle a couple of years ago. I added some logos from my favorite football team and did drive it to a couple of football games.
It is the right color (red).
It has a 3rd party radio that whoever installed it didn't know what they were doing. It rumbles everytime you start and drive the vehicle. I am now ear blind to it. I don't hear it anymore.
For the most part this is a decent vehicle. I have replaced the battery recently and done some other maintenance on it.
I am hoping to get some more information from this forum to help me troubleshoot the current issues. If I don't get this resolved I might just have to put it out to pasture and let it go.
@Rbramble2019; Welcome to the forum;

Post some pics of your Commander when you can; Here are some links if you want to order any other parts for repairs or upgrades to your XK;

Chrysler/Jeep Factory Parts: https://www.factorychryslerparts.com/

North American Parts: https://northamericanparts.rpmware.com/store/account/login.aspx

JeepinByAl: JBAoffroad.com

JustforJeeps.com - https://www.justforjeeps.com/

Rough County lift kits - Suspension Lift Kits, Body Lifts, Leveling Kit, 4x4, Jeep, Chevy, Dodge, Ford, Off-road Truck | Rough Country Suspension Systems®

AFE: Advanced FLOW Engineering | Engineered Adrenaline

CARiD.com - https://www.carid.com/?gclid=CjwKEAjwiYG9BRCkgK-G45S323oSJABnykKAhh8eDfktvKOcXIbZZtyM9MiasWVk-Mba45s2yxNrrxoCEBbw_wcB

Bilstein shocks & struts - Home

WAM Custom Bumpers - https://wambumpers.com/

JeepSteel Custom Bumpers - https://www.jeepsteel.com/

4WheelParts.com - Truck Parts & Jeep Parts - Lift Kits, Winches, Tonneau Covers, Tires, Wheels, Bumpers, Performance ? 4 Wheel Parts

RockAuto - https://www.rockauto.com/en/catalog/jeep,2006?a=Referer+www.google.com+URL+/en/catalog/jeep

Also, please read this if you haven't done so - lots of good information in here;

REQUIRED READING!!! New Member Introduction post & other important new member info.

Thanks and again, welcome aboard.
 

·
Super Moderator
Joined
·
5,845 Posts
It is not repeatable, I can't do something and know it will happen. It just does it's crazy motions almost none stop.
I know it has to be an electrical issue but I don't know where to begin.

Can someone tell me where to begin. I have a fix'd fob that I can connect and get the engine codes. I have looked at them but they are not specific enough to find the issue.

Thanks
Ron
Ron;

First off; Posting the specific DTC codes you are receiving would be a good start, for anybody that's trying to help you;

I always refer anybody who is having electrical problems here;

https://www.jeepcommander.com/forums/10-electronics-nav-discussion/55657-junction-block-explained.html

This is an excellent thread about the Junction Block with detailed information, pictures and diagrams. The Junction block is the assembly located under the dash just to the left of the steering wheel. It contains 30 fuses and has many of the electrical circuits used in the Commander. There is also a PDF document attached to the thread above, that explains in detail how to remove your Junction Block, in the event that you need to replace it.

Since you've had water leaks in the past, I think a thorough inspection of your junction block, the associated wiring going to and coming from it, as well as all of the fuses contained within it, is in order. It may potentially need to be replaced.

I would also get your battery checked again, make sure it's still good. If your battery checks out good and your junction block, associated wiring & fuses look good, the next thing I'd start looking at is your alternator.

There is also a yellow wire that connects to your starter. When this yellow wire connection to your starter gets corrosion on it, it's been known to cause a lot of electrical problems. Check the connection where that yellow wire connects to your starter - if there is any corrosion present on that connection, disconnect your battery and clean that connection with a wire brush until it is completely clean and free of corrosion; Then reconnect your battery and see if there are any changes.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Thanks for the info. I will definitely check out the junction block. I will have to look at it this weekend when I have more time to look. I will also look at the starter and check that out.


The fix'd codes that I pulled today are listed here
Battery Power to Module disconnected P1684. This is expected since I just disconnected the battery a couple of days ago.
Unknown Issue C121C. It has a picture of the ABS on it.
Exhaust Gas Recirculation Position Sensor Circuit High P0406
Cylinder Misfire Fault Detected Random Cylinders P0300
Crankshaft Position Sensor P0335
 

Attachments

·
Super Moderator
Joined
·
5,845 Posts
Thanks for the info. I will definitely check out the junction block. I will have to look at it this weekend when I have more time to look. I will also look at the starter and check that out.

The fix'd codes that I pulled today are listed here
Battery Power to Module disconnected P1684. This is expected since I just disconnected the battery a couple of days ago.
Unknown Issue C121C. It has a picture of the ABS on it.
Exhaust Gas Recirculation Position Sensor Circuit High P0406
Cylinder Misfire Fault Detected Random Cylinders P0300
Crankshaft Position Sensor P0335
That's the first place I'd start; Also if you want more detailed explanations of those trouble codes, you can check here;

https://www.jeepcommander.com/forums/58-diagnostic-trouble-codes-dtc/

Jeep Grand Cherokee WJ - Diagnostic Trouble Codes

https://www.transmissionrepaircostguide.com/jeep-commander-transmission-problems/
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
I took the information from this post to a local mechanic shop that is near my job.
He called me and told me that it was the BCM. Body Control Module.

I called a local recycle shop and they found one.
It wasn't the BCM but the ECM -- Engine Control Module.
So after waiting another week I finally got the BCM.
Tonight I replaced it but I am still getting the same issue.
I took a screenshot of the DTC codes from my fixit application and my vehicle is still having the same issues.
 

Attachments

·
Super Moderator
Joined
·
5,845 Posts
I took the information from this post to a local mechanic shop that is near my job.
He called me and told me that it was the BCM. Body Control Module.

Does anyone know if the BCM needs to be programed to my vehicle? I know the ECM does.
Ron;

That screen shot does not say Body Control module; I had to save your screenshot and then blow it up large enough where I could read it;

It says "P1684" Battery to Control Module;

P1684 Battery Loss In The Last 50 Starts; The battery has been disconnected within the last 50 starts. starts (status indicator only - NOT a reported fault code)

It also says unknown issue with a code of "C121C' and Exhaust Gas Recirculation Position Sensor Circuit High with a DTC "P0406".

P0406 Exhaust Gas Recirculation Sensor A Circuit High; EGR position sensor input above the acceptable voltage range.

Let me preface this by telling you that I'm not anything close to a qualified mechanic;

I'm just trying to use some common sense here; Sounds to me like you have an electrical/voltage problem going on- possibly a short somewhere that you are going to have to chase down; If it was me, I start by getting your alternator checked and make sure it's good; After you get the alternator checked, get your battery checked again and make sure it's still good;

Also Ron, did you ever check the connection for the yellow wire going to the starter for corrosion, like I mentioned to you previously?

If you go through these 2 evolutions and everything checks out o.k. I'd start looking for a reputable automotive electricians shop and see if they can't find out where your short is, because it sure sounds to me like you have some kind of short in your electrical system somewhere, that is causing voltage irregularities.
 

·
Registered
Joined
·
147 Posts
It sounds you are quickly going to surpass the threshold of just paying a diagnostic charge to just have the dealer figure out the problem for you.
1 suggedtion i have is check your ground straps in addition to the yellow wire mentioned earlier. Bad grounds are notorious for causing intermittent issues too.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
OK
A lot has happened with my Jeep since I have been gone.

I have replaced both the ECM and the BCM control module.
I replaced the ECM yesterday and the headlights aren't flashing like they were doing last time.
The gauges all still flash. The turn signals don't flash properly. The gauges are now saying check gauges frequently.


I don't know if taking it in to a dealer will help out better or not.
I don't think I can drive this vehicle with all these issues. The radio doesn't work. If i use the Bright lights they will flash about every minutes or less.


Any more ideas?
 

·
Super Moderator
Joined
·
14,970 Posts
OK
A lot has happened with my Jeep since I have been gone.

I have replaced both the ECM and the BCM control module.
I replaced the ECM yesterday and the headlights aren't flashing like they were doing last time.
The gauges all still flash. The turn signals don't flash properly. The gauges are now saying check gauges frequently.


I don't know if taking it in to a dealer will help out better or not.
I don't think I can drive this vehicle with all these issues. The radio doesn't work. If i use the Bright lights they will flash about every minutes or less.


Any more ideas?
I know this doesn't sound like it could be related, but try putting in a new light stalk. Bad ones have caused the dash lights to flash.

.
 

·
Registered
Joined
·
147 Posts
Try turning off your AUTO High Beams, in your Dash options. The oncoming light sensors dont work very well, especially in the city.
 

·
Super Moderator
Joined
·
5,845 Posts
OK
A lot has happened with my Jeep since I have been gone.

I have replaced both the ECM and the BCM control module.
I replaced the ECM yesterday and the headlights aren't flashing like they were doing last time.
The gauges all still flash. The turn signals don't flash properly. The gauges are now saying check gauges frequently.


I don't know if taking it in to a dealer will help out better or not.
I don't think I can drive this vehicle with all these issues. The radio doesn't work. If i use the Bright lights they will flash about every minutes or less.


Any more ideas?
@Rbramble2019; Did you ever have your junction block checked out like I suggested to you in the very beginning of this thread?


Big Blue said:
I always refer anybody who is having electrical problems here;

https://www.jeepcommander.com/forums...explained.html

This is an excellent thread about the Junction Block with detailed information, pictures and diagrams. The Junction block is the assembly located under the dash just to the left of the steering wheel. It contains 30 fuses and has many of the electrical circuits used in the Commander. There is also a PDF document attached to the thread above, that explains in detail how to remove your Junction Block, in the event that you need to replace it.

Since you've had water leaks in the past, I think a thorough inspection of your junction block, the associated wiring going to and coming from it, as well as all of the fuses contained within it, is in order. It may potentially need to be replaced.

I would also get your battery checked again, make sure it's still good. If your battery checks out good and your junction block, associated wiring & fuses look good, the next thing I'd start looking at is your alternator.

There is also a yellow wire that connects to your starter. When this yellow wire connection to your starter gets corrosion on it, it's been known to cause a lot of electrical problems. Check the connection where that yellow wire connects to your starter - if there is any corrosion present on that connection, disconnect your battery and clean that connection with a wire brush until it is completely clean and free of corrosion; Then reconnect your battery and see if there are any changes.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #15
OK this time is a pure example of letting the experts at least diagnose the problem and it might have saved me some money.
I had some major issues and I had the engine replaced and the wheel bearing and assembly replaced.
The engine is not related to this issue. The wheel bearing was also not related it was very noisy so i had to replace it.

Even after I replaced the BCM $150, the ECM $280 plus a week and 1/2 half of down time while I sent the ECM in to get it reworked. I also went to an Battery / Electrical shop about 1 block from my work. They said the alternator was bad and that was replaced $285. The shop mirrored what someone in this thread mentioned.

"Sometimes it is better to bite the bullet and take it to the dealership"
Well I took it to the local dealership in Joplin and 3 hours later and $85.00 (diagnostic fee) they said that the heated seat module had oil / water leaking around it and it was shorting out. They said they could fix it for another $341 but that for now they were leaving the module unplugged.

The lights stopped flashing, the turn signals now work properly, the radio even comes back on and allows me to reprogram it to my stations. Everything seems to be working now except the heated seats which is a luxury.

All I have to say now is this vehicle better treat me well for the foreseeable future.
 

·
Super Moderator
Joined
·
5,845 Posts
OK this time is a pure example of letting the experts at least diagnose the problem and it might have saved me some money.
I had some major issues and I had the engine replaced and the wheel bearing and assembly replaced.
The engine is not related to this issue. The wheel bearing was also not related it was very noisy so i had to replace it.

Even after I replaced the BCM $150, the ECM $280 plus a week and 1/2 half of down time while I sent the ECM in to get it reworked. I also went to an Battery / Electrical shop about 1 block from my work. They said the alternator was bad and that was replaced $285. The shop mirrored what someone in this thread mentioned.

"Sometimes it is better to bite the bullet and take it to the dealership"
Well I took it to the local dealership in Joplin and 3 hours later and $85.00 (diagnostic fee) they said that the heated seat module had oil / water leaking around it and it was shorting out. They said they could fix it for another $341 but that for now they were leaving the module unplugged.

The lights stopped flashing, the turn signals now work properly, the radio even comes back on and allows me to reprogram it to my stations. Everything seems to be working now except the heated seats which is a luxury.

All I have to say now is this vehicle better treat me well for the foreseeable future.
That's a familiar quote.

Well, I suspected you had a short in your electrical system somewhere but I would have never given a thought to the heated seat module, that's a first. Good to know though, thanks for sharing.
 
1 - 16 of 16 Posts
Top