Jeep Commander Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1 (Edited)
First time poster, long time reader here. Great site, looking to contribute and seek knowledge. The 2 problems that I am having are...
1. A/C and Heater Control Switch not blowing as fast
2. Service Park Assist System message coming on
Any input would be much appreciated fellow Jeep Commander Bro's and Sis's!
 

·
Registered
Joined
·
1,515 Posts
Do you have the single or dual Ac/Heater controls, Hard for a FL person to know and I have not been back in central PA in cold weather ever in my xk. If your XK has the dual controls auto seems to work best.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Creek, thanks for the input. Mine is just the single. I think it may be time to get a new control switch, especially this those cold PA winters knocking at the door.
 

·
Super Moderator
Joined
·
5,920 Posts
First time poster, long time reader here. Great site, looking to contribute and seek knowledge. The 2 problems that I am having are...
1. A/C and Heater Control Switch not blowing as fast
2. Service Park Assist System message coming on
Any input would be much appreciated fellow Jeep Commander Bro's and Sis's!
@jlmank33;

Welcome to the forum.

The Service Park Assist System message is most likely coming on because the park assist sensor in the rear bumper probably needs to be replaced.

This is somewhat common, I replaced mine 1 1/2 to 2 years ago.
 

·
Super Moderator
Joined
·
5,920 Posts
Thanks for the reply Blue! Is there any way to tell which one exactly?
I went to the dealership and had them read the DTC in the EVIC and they determined the park assist sensor in the rear bumper was bad and had shorted out.

They replaced it and I've had no more issues since.
 
1 - 10 of 10 Posts
Top