Jeep Commander Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
So the saga continues with this 09 Commander. Took it to a mechanic since I work swing shift and don't have the time to fix it in a timely manner. He concluded it has a burnt valve by running several different tests. I bought a 2012 engine from a truck with 39k miles. He has it swapped in with all the Jeep specific parts changed over. He can't get it to run, it turns over great but no injector pulse. It isn't throwing any codes at this time. My question is what engines are compatible for this 09? I've read stuff here and there that 2009 Jeep was a unique beast. It supposedly has the old 32 tooth reluctor wheel but has VVT? As far as longblocks go, what came out and what went back in look identical with what you can see. Interchanges online aren't much help but they aren't showing anything newer than 2013. This leads me to believe this engine may be a 2014 or newer if Chrylser indeed changed it but could also be something totally different since it is from a truck. I would appreciate an education on the changes in the HEMI through the years and platforms.


Thanks
Kane
 

·
Super Moderator
Joined
·
15,103 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #3
FYI
The truck was supposedly a 2012 HEMI Ram 1500. Ended up being a 2013 when the block numbers were ran. Tore it down to a long block and reassembled with the Commander oil pan, timing cover, intake, exhaust, and accesories. The mechanic scanned it with a high end Snap-on tool after doing an update to his software and found it to be something in the security settings. Did a quick reflash and it started right up.


Kane
 
1 - 3 of 3 Posts
Top