Jeep Commander Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey just stopping in to say Hi, recently purchased a 2006 Jeep Commander Limited 5.7, shes a bit of a lemon, but engine, tranny, and 4wd all checked out good so I picked her up as a project.

My first American vehicle ever, so learning all the basics as I go, prior I had a 03 Bmw M5, and a 92 Bmw 850I, so I bit of a do it yourself and hope for the best kinda guy.

so alittle about the vehicle

2006 Gold/Tan Leather
(fully loaded as far as I can tell)
vehicle appears to have been in an unreported accident as when I pulled the Carfax nothing came up, however a lot of body panels have been replaced. as well as new welding points under hood where front headlights mount up
148k Miles
Minor moisture damage inside the dash, and to the flooring some rust (northwest car)
sunroof drains were severley clogged, and the sunroof was silicone sealed (lmao) so on the first rain after owning, my floors and dash were soaked, had to remove both drain tubes entirely from vehicle and snake them.

sunroof now operates beautifully, silicone removed.

had a radiator leak, and like a chump I used a radiator coolant sealer. totally killed my thermostat. So pu in a New water pump and thermos, cleaned everything up, flushed radiator and engine block as best as possible.

currently she still has a few quirks
drivers/passenger front windows don't operate, rear passenger window does not operate, (rear driver window DOES work) tested all motors successfully with jumper cables and some wiring, replaced switch still no success in getting them to work properly, mirrors are not working as well, and interior lighting does not work properly (they come on, but if I click both front lights on manually they dim to the point of uselessness and do not turn off automatically when exiting and locking car (possible connector or wiring issue in dash maybe from sunroof overflowing into dash. so I have them manually turned off till I can troubleshoot them more efficiently.
loud whine sound from 35+ miles an hour that changes pitch when I turn (will replace both front wheel bearings and hubs) clunking sound when doing sharp slow turns (thinking the control arm coming out of the rack and pinion is possibly stripped)

annoying clicking sound when accelerating when vehicle cold (fast paced and electronic sounding (research points to low transfer case fluid?)

vehicle was only 3k flat from one of those off the road shady no financing dealerships, so I knew i'd be dropping a bit of cash into her as I go.

i'll post some pictures in the next day or 2, seems I still need to get the ignition recall addressed, as well as the 73. 4wL didn't work until I did the fuse pull trick, now it operates properly until they to the update.
 

·
Premium Member
Joined
·
294 Posts
73 recall

I would take it in for the recall and show them that the 4 lo is working before you leave it with the dealer and check it after the recall to see if it still works as then you can show the same person that it does or doesn't


Swanny
 

·
Super Moderator
Joined
·
5,881 Posts

·
Registered
Joined
·
309 Posts
You can have the dealership baseline your electronics in the vehicle and just start over with all the computer recall updates.
That will help on the glitchy windows, those things are tied into the controller modules and have to be calibrated. That will also effect the A/C performance since the senses the state of the windows and sunroof.
Your headlights will also get affected by the new software programming, those run off of one of the forward controllers also.

I learned a lot about the CANbus system and what systems work together for the computer to get a system state of health.

Sometimes a system complete redo is worth the effort to get rid of older bugs in the memory. The you can save the file on a programmer so you have a good backup file for yourself in the future.

Dave
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
oh really? headlights appear to work fine tbh, oh wait the auto on doesn't work, but otherwise they do work great, interior lights are the weird one, when I only click one on its bright but if I click both fronts on all interior lights dim drastically. that's a weird one.
 
1 - 6 of 6 Posts
Top