Jeep Commander Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Anyone ever have any trouble trying to upgrade their lighting? I have an 06 and tried hooking up HIDs and they wouldn't work together, Just one at a time. Not sure if it's just my old ass wiring or not but i also set it up with capacitors and they would work but eventually shut off. I then tried LEDs that I got for the fogs and they seemed to work fine. I then went back to the stock halogens and they didnt come on immediately until I gave them a shake, now seems fine. Am I missing something here? Or is my truck just getting old?
 

·
Administrator
Joined
·
6,634 Posts
Anyone ever have any trouble trying to upgrade their lighting? I have an 06 and tried hooking up HIDs and they wouldn't work together, Just one at a time. Not sure if it's just my old ass wiring or not but i also set it up with capacitors and they would work but eventually shut off. I then tried LEDs that I got for the fogs and they seemed to work fine. I then went back to the stock halogens and they didnt come on immediately until I gave them a shake, now seems fine. Am I missing something here? Or is my truck just getting old?
@FrankWhite06;

Based on what you're describing, it sounds like faulty wiring to me.

I'd also suggest checking your battery and making sure it's strong & fully charged; It might be time to replace it.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
@FrankWhite06;

Based on what you're describing, it sounds like faulty wiring to me.

I'd also suggest checking your battery and making sure it's strong & fully charged; It might be time to replace it.


Ok thank you, so typically these can just be HID'd or LED'd with no extra steps?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
Ok thank you, so typically these can just be HID'd or LED'd with no extra steps?
 

·
Administrator
Joined
·
6,634 Posts
Ok thank you, so typically these can just be HID'd or LED'd with no extra steps?
That's correct @FrankWhite06. I have not heard of anyone having problems with HID's before.

LED headlights (which I have currently) come with anti-flicker harnesses which eliminate any potential electrical compatibility issues.

But again, I'd check your battery and make sure it's 100%.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
That's correct @FrankWhite06. I have not heard of anyone having problems with HID's before.

LED headlights (which I have currently) come with anti-flicker harnesses which eliminate any potential electrical compatibility issues.

But again, I'd check your battery and make sure it's 100%.
Looks like my battery is a little over 4 years old so I should probably start by replacing it
 

·
Registered
Joined
·
25 Posts
Discussion Starter #8
Thank you, I'll start there, try the HIDs again, if they still don't work then I try something else
 
1 - 8 of 8 Posts
Top