Jeep Commander Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Not sure what's going on here lately. Temperature dial on both is turned to the left to the blue dot. Fan is off, all the way to the left also. No fan motor of any sort is on, but for some reason HOT air can be felt coming from the dash up front by the windshield. It's not blowing, it's just like radiant heat current moving up, any clue to what this is. Also, doesn't matter what the select position it is on; feet, feet/defrost, straight front etc...

2006 5.7 Limited

Thanks
 

·
Registered
Joined
·
371 Posts
Sounds like there is something broken in the system. You should check to see if one of the gears or levers is broken .
 

·
Banned
Joined
·
159 Posts
My wj did this when the blend doors broke and received door broke. I would say do whatever needs to be done to get into you heater for box and double check that all is good. Also on my wj there was a way to hold some buttons on the climate control and turn a knob and it would go into diagnose mode. Told me what was wrong. Not sure if the XK has that, but worth looking into.
 

·
Super Moderator
Joined
·
5,846 Posts
My wj did this when the blend doors broke and received door broke.
This is most likely the issue;

Broken blend doors or stripped/broken blend door gears are a common problem on XK's.

Unfortunately, if you are diagnosing this yourself, the only way to really verify this is to do some disassembly and visually inspect your blend doors and the gears that actuate them.
 
1 - 4 of 4 Posts
Top