Jeep Commander Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2007 Commander V6. My engine light appeared so I had the computer read at my local big box parts store. The error was for a bad or poorly adjusted idle sensor.

Question 1: Where can I locate that part on my engine?

Question 2: Occasionally I will briefly lose power while driving. The engine never dies but loses power for 15-30 seconds, then power surges back to normal performance. Are these two things related?

If I need to provide more detail, please ask questions so I know what to provide.

Thanks!
 

·
Registered
Joined
·
532 Posts
did you get an error code? is v6 crd or gas?
 

·
Registered
Joined
·
556 Posts
Theres an idle air control (IAC) sensor located on the right side of the throttle body, under the air plenum. Its not a very expensive part. search it here and you'll see that others have replaced this to correct the rough idle.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
did you get an error code? is v6 crd or gas?
I didn't get a code from the parts store, he just told me it was an idle sensor error. It's a gas engine.

Theres an idle air control (IAC) sensor located on the right side of the throttle body, under the air plenum. Its not a very expensive part. search it here and you'll see that others have replaced this to correct the rough idle.
Thank you! I'll snoop around that spot and get 'er swapped out.

Thanks for the help.
 
1 - 4 of 4 Posts
Top