Jeep Commander Forum banner

1 - 7 of 7 Posts

·
Banned
Joined
·
159 Posts
Discussion Starter #1
Does anybody have instructions or a diagram on removing the interior trim panels in the rear? Trying to get access to my power lift gate assembly so I can try and trouble shoot why its not working. It looks as if there are three screws holding it in place but i pulled those and it still wont budge. Tried google and searching sorry if this comes up, and I missed it.
 

·
Super Moderator
Joined
·
5,845 Posts
Does anybody have instructions or a diagram on removing the interior trim panels in the rear? Trying to get access to my power lift gate assembly so I can try and trouble shoot why its not working. It looks as if there are three screws holding it in place but i pulled those and it still wont budge. Tried google and searching sorry if this comes up, and I missed it.
Are you talking about the interior trim panel on the rear hatch door?

If so, I've done it and there really is not that much to it, just a few screws (5 if I remember right) and some push pins/clips (3 or 4).

You just have to be careful when popping the push pins/clips out, since they are 10 or 11 years old in most cases - and made of plastic, they tend to be brittle from heat exposure over time and will break rather easily if you are not careful.
 

·
Premium Member
Joined
·
294 Posts
Parts Diagram

Go to www.moparpartswebstore.com and enter your model and info they have parts lists for most mopars. But if your door goes up with the button either front or rear but does not go down with the rear button when it is open, trey raising the door by hand until it is in the top position and if that makes the door go down with the button then the gas strut is bad and not raising it open far enough to tell the Jeep it is in the up position. (I.E. bad strut).


Swanny
 

·
Super Moderator
Joined
·
5,845 Posts
Get a set of the plastic pry tools. Much better than breaking pieces off
Yep, after that job - when I broke off one of the clips for the rear hatch interior door panel, I ordered these which were pretty handy when I installed my Chrome rear grab handles;

https://www.amazon.com/gp/product/B0002SRCMO/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

https://www.amazon.com/gp/product/B00A14H3TG/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

One has more of an angle then the other, that's why I got them both.
 

·
Banned
Joined
·
159 Posts
Discussion Starter #6
It's not the rear hatch panel I need to get off its the interior rear quarter panel (???). There is an upper and a lower portion and I can't seem to get either one of them lose. I took out the screws and am guessing there are those little metal slot inserts but I don't know their location so I'm not sure where specifically to pry.

As for my lift gate, it is completely inoperable. Front button, back button, keyfob... I get nothing. The fob button will make the lights flash but nothing actually happens. Do you guys any sort of notification on the evic when it works?
 

·
Super Moderator
Joined
·
5,845 Posts
It's not the rear hatch panel I need to get off its the interior rear quarter panel (???). There is an upper and a lower portion and I can't seem to get either one of them lose. I took out the screws and am guessing there are those little metal slot inserts but I don't know their location so I'm not sure where specifically to pry.

As for my lift gate, it is completely inoperable. Front button, back button, keyfob... I get nothing. The fob button will make the lights flash but nothing actually happens. Do you guys any sort of notification on the evic when it works?
Try disconnecting your battery for 15 minutes and then reconnect it and see what happens.
 
1 - 7 of 7 Posts
Top