Jeep Commander Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
2007 Commander with the 4.7LV8 flex-fuel engine and about 85,000 miles on it.

Trying to feel out a problem right now. 2 times now it has acted like a dead battery when you try and start it. Turn the key over and all it does is click. The first time I thought it was a dead battery and I hooked up the cables and jumped it. Fired right up so I still thought dead battery. Odd thing is the battery is 1 year old and when I opened the door the lights seemed normal and I did not have a volt meter with me to confirm anything.

Fast forward to a few weeks ago and it did it again except this time it was at home. Still thinking it was the battery I tested the voltage in the battery and it read 12.67V which told me it was not a battery issue. Turned the key and click, click, click then finally it turned over weakly and fired right up.

Each time was on a different key so I don't suspect the theft system to be an issue. My dad suggested that it could be the starter solenoid getting weak.

Like I said it has only been 2X now so I hate to throw parts at it right now but at the same time if that is the problem I don't want it to wait until the dead of winter at the grocery store to finally give up the ghost.

Any thoughts? Is there a way to test the starter solenoid?

Thanks in advance.
 

·
Registered
Joined
·
405 Posts
I would say take your Jeep to autozone and have them do a free alternator and battery test. At least that is what i would do. My .02 cents. Hope you find a solution.
 

·
Registered
Joined
·
127 Posts
ive had the same issue for about 2 years now, ive noticed that when you get that click moving the shifter left/right when its in P the Commander starts right up fine. It will turn on when in N as well. Might be a sensor that tells the computer that its not in P or N and then you get that click. turning the commander off might reset the sensor so it fires up with no issue after that.
 
1 - 4 of 4 Posts
Top