Jeep Commander Forum banner

1 - 3 of 3 Posts

·
Banned
Joined
·
139 Posts
Discussion Starter #1 (Edited)
So I have a 2010 Limited which came with the iPod hook up in the glove compartment. Probably the same for 2009 Limiteds. I assume this is the same connection offered by Mopar as an aftermarket accessory.

Is it just me or is it extremely difficult to connect the cable (supplied by Jeep) to the “hook up” that is attached to the back of the glove box? The way it is installed from the factory makes for an extremely close fit.

There is an “insert” in the “hook up” that I was able to remove. Looks like a cap or plug of some sort. I just can’t physically plug the cable in.

I honestly cannot do it. Feels like I will break it if I force it.

Anyone else have these issues?

Any tips or suggestions?

Somebody help me! Meatball, Sausage, Braciole! Anybody!

:icon_confused:
 

·
Registered
Joined
·
1 Posts
I am looking for the same thing as well if anyone can help. I have a 2010 as well that came with a plug in the glove box and a maybe 8 inch pigtail that fits my Ipod but cannot get that pigtail into that plug. It looks like it should just wont go. Am I missing a piece or what??? Thanks.
 

·
Registered
Joined
·
9 Posts
I have the same connection in my 2010. It had a cap on the end of the ipod connection cord which I removed and then plugged into the other cord already in the glove box. I had no problem installing it other than my large hands getting in the way.
 
1 - 3 of 3 Posts
Top