Jeep Commander Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So I bought a 2010 jeep commander with the 5.7 hemi, my question is was it a good move it had 136,000 but the motor sounds great, the thing that worries me is now I'm seeing the 5.7 has alot of problems with the mds feature literally destroying engines, is it an issue and if so can I deactivate the mds feature ?
 

·
Administrator
Joined
·
15,331 Posts
@Mikecommander1801 Welcome to the forum! Please make an introductory post in the New Member Section when you get a chance. Thanks. As for your concern about the MDS, I have been on this forum for 14 years and have never seen anything about the MDS destroying an engine. I also have a 5.7 HEMI Commander that is 14 years old and have never had a problem with the MDS or the engine. But you have to make sure you use the recommended 5W20 oil in it, otherwise the MDS will not operate properly.
 

·
Administrator
Joined
·
6,446 Posts
So I bought a 2010 jeep commander with the 5.7 hemi, my question is was it a good move it had 136,000 but the motor sounds great, the thing that worries me is now I'm seeing the 5.7 has alot of problems with the mds feature literally destroying engines, is it an issue and if so can I deactivate the mds feature ?
@Mikecommander1801 ;

Welcome to the forum; Please read the New Member Required Reading below and complete your user profile as directed, in order to comply with the forum rules;


Thanks & welcome aboard.
 

·
Premium Member
Joined
·
683 Posts
Haven't heard of MDS causing problems, the Hemi does have a problem in the earlier years of dropping valve seats that pretty much destroy it. Usually happens in an engine that has overheated.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Ok awesome thanks guys it was just concerning, I saw a few people complaining about replacing engine after engine. Well I like my commander so far its brilliant black, has the limited trim and all the bells and whistles.
 

·
Registered
Joined
·
5 Posts
Absolutely never heard of it destroying an engine. The only time I have ever sold one, was because someone used the wrong type of oil, and it tripped a code for the MDS. Just re do the oil with 5w-20 abd the MDS works just fine
 
1 - 6 of 6 Posts
Top