Jeep Commander Forum banner

1 - 10 of 10 Posts

·
Premium Member
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Been a member of this forum since last year - Thanks for all the advice and information!

I'm searching for any previous posts regarding issues encountered during install of a bug deflector - Wanted to create a new post, but I think I have to complete this step first -

I'm having issues installing a "simple" AVS bug deflector on the hood - once deflector is installed, hood will not close securely -
I have made several adjustments, only to end up with the same results -

any of you fellow jeepers have advice on how to remedy this issue?

Thanks in advance!
 

·
Registered
Joined
·
480 Posts
Have you tried adjusting the hood stops? They're the hexagonal pieces sticking up on either side of the radiator support bar, and you can unscrew them or screw them in to raise or lower the hood's resting position. Maybe you can adjust them to get the hood correctly positioned.
 

·
Registered
Joined
·
76 Posts
I love my 2006 XK Hemi too! Even after a catastrophic engine failure, a ridiculous recall that stole my 4wd low, lifter issues, and lots of minor headaches.
 

Attachments

·
Registered
Joined
·
13 Posts
If it's what I'm guessing, the 2006-2010 line had valve issues. The seats would break and fall into the chamber, highly likely that the kind of catastrophic failure this would cause could damage the intake manifold when metal flies upwards into it, leaving it to be replaced as well. Mine made it to 108k before this failure, most of them start to break from this at around 75-85k. Mine lasted til 108k, then it was time for a reman. I'm looking to keep it for another ten years at least.
 

·
Super Moderator
Joined
·
5,763 Posts
Been a member of this forum since last year - Thanks for all the advice and information!

I'm searching for any previous posts regarding issues encountered during install of a bug deflector - Wanted to create a new post, but I think I have to complete this step first -

I'm having issues installing a "simple" AVS bug deflector on the hood - once deflector is installed, hood will not close securely -
I have made several adjustments, only to end up with the same results -

any of you fellow jeepers have advice on how to remedy this issue?

Thanks in advance!
Remove your bug deflector; Problem solved.
 

·
Registered
Joined
·
336 Posts
Have you tried adjusting the hood stops? They're the hexagonal pieces sticking up on either side of the radiator support bar, and you can unscrew them or screw them in to raise or lower the hood's resting position. Maybe you can adjust them to get the hood correctly positioned.

wonder if he's coming back?
 

·
Super Moderator
Joined
·
5,763 Posts

·
Premium Member
Joined
·
4 Posts
Discussion Starter #10
FYI - @rewdboy has been back on the forum since cbw's reply on the 12th; He has posted in this very thread on the 14th & the 17th; he just has not responded to @consumedbywater's reply for whatever reason.
I'm back - didn't have an opportunity to adjust the hood settings until the other day - this simple adjustment did the trick, just a few twists to lower the hood stops on each side was all that was needed - thanks @consumedbywater !
@BigBlue: didn't bother with your suggestion since this would totally invalidate the purpose of purchasing the bug deflector -

Love this forum!
 
1 - 10 of 10 Posts
Top