Jeep Commander Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
The knob to adjust air to defrost/feet/vent ect. isn't working. I wouldn't care but I need a defroster for the winter. Its only on feet/vent and wont switch to anything else even though I move the knob. ( I just had the Jeep in to the dealership to replace the resistor, the air would only work on high.) I hate dealing with them........ any suggestions and/or anyone have the same problem. Thanks for the help, much appreciated
 

·
Registered
Joined
·
47 Posts
Havent torn into one on a Commander yet, but had the same thing on my TJ. the control that the knob slides onto is round with one flat side, my knob (being plastic) had cracked and as a result the knob was just rotating on the stem, not actually moving it. I just pulled the knob off and used a pair of pliers to change the settings until I was able to get a new knob. I will try and take a look at the wifes commander tommorrow and see if it is a similar setup.

Hope this helps
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
thanks a lot for the reply i appreciate it, i need to see if its doing the same thing
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Well I don't think the knob is broken because I feel it hit every position. I checked the fuses and all seems fine, does anyone else have suggestions I could try.
thanks.....
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
robby said:
Gotta wonder if something didn't get knocked off, or not reinstalled when the control panel was reinstalled while diagnosing blower problem.

........Rob
I was wondering the same thing........
 

·
Registered
Joined
·
5,610 Posts
Yeah, they didnt plug it back into the knob, there are 5 plugs I think in the back of the panel. I bet they forgot to plug it in when they re installed the front panel. Take off the dash and then the chrome ring around the shifter. pull the panel out and look for loose wires. wont take 10 minutes.
 

·
Registered
Joined
·
5,610 Posts
REMOVAL


1. Remove the 16 screws and using a trim stick C-4755 or equivalent, separate the trim bezel and remove.



2. Using a trim stick C-4755 or equivalent, remove the shifter bezel ring.



3. Using a trim stick C-4755 or equivalent, remove the shifter bezel.


4. Using a trim stick C-4755 or equivalent, remove the center bezel and disconnect the electrical connectors.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
thanks for the idea, ill try it out today and see if they "forgot" to plug it in
 

·
Registered
Joined
·
16 Posts
Discussion Starter #10
cico7 said:
Yeah, they didnt plug it back into the knob, there are 5 plugs I think in the back of the panel. I bet they forgot to plug it in when they re installed the front panel. Take off the dash and then the chrome ring around the shifter. pull the panel out and look for loose wires. wont take 10 minutes.
YEP!!!!! they didn't push one of the plugs in all the way. Glad I didn't have to bring it back in. Thanks for the help. I appreciate it.
 
1 - 10 of 10 Posts
Top