Jeep Commander Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
Motor started to ping at start up. It has made a little noise for some time. Changed the oil this past week. Mobil one 5w20. It almost sounds like a bag of marbles now. Oil level is correct. No low oil pressure light ( wish it had a gauge). Performance is normal. What gives. Should I flush it. Try some lucas.??????? Don't know where to go. I hate putting stuff other than oil in the motor. Anybody come across this. And any suggestions on what to do would be appreciated. Getting ready to do my superlift in a few weeks. And this is bumming me out.
 

·
Registered
Joined
·
158 Posts
The oil your using isn't what is specified for that year. You should be using 5w-30, to start. I would first try to detemine where the noise is coming from. Your right, an oil additive is probably not going to fix what you have going on. Do you nean pinging, as in spark knock?
 

·
Registered
Joined
·
172 Posts
probably a lifter. Had exactly the same symptoms in my 4.7 Durango, lifter noise is very common on these motors.

And yeah, definitely change to the weight the motor is spec'd for - 5w-30.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #5
Sorry I ve been tardy. It seems my lifters are the culprit. I havent checked out the exhaust, But i do suspect my drivers side probably has a broken bolt. The noise is definitely coming from under the valve covers. It is real common on the 3.7 and the 4.7 which is mine. I must have a little build up not allowing the Lash adjusters to fill. I see I can get a set for under $100. After the lift I'll look into it. Just waiting on the lift still. Superlift had to have some parts made thay didnt have it all in stock. At least thats what 4wd.com is saying. I hope that they get it here before The 14th of May, I took a vacation week so i could do install it. That way i'm not under the gun to get it done in a day or two.
 

·
Premium Member
Joined
·
6,309 Posts
Did you ever get this fixed??? My XK makes the same noise...
 
1 - 6 of 6 Posts
Top