Jeep Commander Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Driving home from Birmingham my jeep commander 2007 had the transmission light come on and said transmission overheating pulled over checked the fluid then added a tiny bit of water but ran water over the motor IDK

drove it about two more miles it cut off and had to get out and push it over the interstate bridge thankful for thew man that stopped and helped me push it


Every time I tried to start not after I got it home it sounded like the started was spinning it wouldn't catch

then I changed the started and its still sounds like the starter is spinning

Looked it up said there was a real or something on the transmission sensor


not sure but I am stuck

with no jeep to get where I need to get to


Feeling like we all need to come together and petition jeeps manufactory

any ideas what is wrong with these jeeps
 

·
Registered
Joined
·
86 Posts
Driving home from Birmingham my jeep commander 2007 had the transmission light come on and said transmission overheating pulled over checked the fluid then added a tiny bit of water but ran water over the motor IDK

drove it about two more miles it cut off and had to get out and push it over the interstate bridge thankful for thew man that stopped and helped me push it


Every time I tried to start not after I got it home it sounded like the started was spinning it wouldn't catch

then I changed the started and its still sounds like the starter is spinning

Looked it up said there was a real or something on the transmission sensor


not sure but I am stuck

with no jeep to get where I need to get to


Feeling like we all need to come together and petition jeeps manufactory

any ideas what is wrong with these jeeps
What does water have to do with the transmission? I really hope you didn't put water into your transmission.

Take this to a mechanic! I don't think it's unheard of to have some maintenance issues on an 11 year old vehicle. All vehicles need maintenance now and then, regardless of manufacturer.
 

·
Super Moderator
Joined
·
5,763 Posts
Driving home from Birmingham my jeep commander 2007 had the transmission light come on and said transmission overheating pulled over checked the fluid then added a tiny bit of water but ran water over the motor IDK

drove it about two more miles it cut off and had to get out and push it over the interstate bridge thankful for thew man that stopped and helped me push it


Every time I tried to start not after I got it home it sounded like the started was spinning it wouldn't catch

then I changed the started and its still sounds like the starter is spinning

Looked it up said there was a real or something on the transmission sensor


not sure but I am stuck

with no jeep to get where I need to get to


Feeling like we all need to come together and petition jeeps manufactory

any ideas what is wrong with these jeeps
Whatever is wrong with your Commander - you almost certainly made it worse by trying to continue to drive it; The proper thing would have been to shut it down as soon as the Transmission overtempt trouble code showed up and call a flatbed to have it moved to a reputable shop and have it looked at.

And I don't know what water has to do with the transmission so why you tried adding water, I have no idea.

My advice would be to have taken to a reputable shop and have it properly diagnosed - before you do any MORE damage.
 

·
Registered
Joined
·
21 Posts
Do the V6's have the same Transmission/Engine Connector/Harness as the V8's ? I heard that a good clean/application of dielectric grease works for solving those phantom Trans Over temp and non-starting issues.
 

·
Registered
Joined
·
128 Posts
Do the V6's have the same Transmission/Engine Connector/Harness as the V8's ? I heard that a good clean/application of dielectric grease works for solving those phantom Trans Over temp and non-starting issues.
Can you tell me more about this? I just started getting the phantom Trans Temp warning. I know for fact it isn't over heating cause it'll happen when I'm sitting in the parking lot, or even in the car wash a few days ago it came on for just a quick second. If i get out and touch the transmission there is NO way it's at or over 270*f which is was the FSM says it'll have to get to before it triggering. It's just barely warm. Plenty of fluid and I replaced the lines and cleaned out the cooler not too long ago. No leaks.

I've read that almost always it's some corrosion or a wire somewhere sending false signals to the PCM....but no one actually says WHERE they found and fixed the problem. There are mentions of a Yellow wire at the starter motor, but that is usually coupled with their engine not cranking....which makes sense for them.
 

·
Registered
Joined
·
22 Posts
Ive had a random trans over temp warning when trying to get my DTC codes. IT comes up for about 1 second then goes away
 

·
Registered
Joined
·
128 Posts
Ive had a random trans over temp warning when trying to get my DTC codes. IT comes up for about 1 second then goes away

Yea, that makes sense...i get all sorts of dash lights having a party when i'm pulling codes or doing a tune flash or anything, that's normal.
My problem is sitting in a parking lot or something after driving and the Over Temp comes on and stays on, fan kicks on high for a little while, then it goes away. Then it might come back a few minutes later, etc etc. Doesn't happen when i'm actually driving.

The car wash was one of the few times it just blipped on for like 2 seconds. It hasn't happened in a few days now....so i guess i'll let it ride. but it's going to annoy the crap out of me if it starts coming back....
 
1 - 8 of 8 Posts
Top