Jeep Commander Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have an '06 Commander Limited which I just bought. I've been having trouble with the Nav screen just randomly not coming on when I start the car and randomly going blank when i'm driving down the road. It will also randomly come back on. I'm not sure if there's some secret button to push to get it to come back on, or it needs an update, or it has a short..There's no pattern as to when it goes out..Anyone else ever had this problem?? HELP!
 

·
Banned
Joined
·
1,406 Posts
I had the same problem with my Sony TV - shot, and out of warranty. Picture, no picture, but I always had sound. Random - no rhyme or reason to it. So I bought a Panasonic Plasma. :eek:rangehat:
 

·
Registered
Joined
·
17 Posts
I, too, had the same problem. Would go off and on constantly. Was so irritating (particularly at night) that I stuck my cap over it. Turned out to be an internal connection. Fortunately, it happened less than 10K km from new and the whole unit was replaced under warranty.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I, too, had the same problem. Would go off and on constantly. Was so irritating (particularly at night) that I stuck my cap over it. Turned out to be an internal connection. Fortunately, it happened less than 10K km from new and the whole unit was replaced under warranty.
it pisses me off just because there is no reason and it is totally random. sometimes some of my buttons don't work but i have audio all day long. it will eject cds but not switch from cd to fm/am. its not under warranty so it's looking like im going to have to take it to the dealership and throw out 100 bucks just for them to look at it :mofo:
 

·
Super Moderator
Joined
·
14,914 Posts
it pisses me off just because there is no reason and it is totally random. sometimes some of my buttons don't work but i have audio all day long. it will eject cds but not switch from cd to fm/am. its not under warranty so it's looking like im going to have to take it to the dealership and throw out 100 bucks just for them to look at it :mofo:
They will tell you they don't fix them, they only replace them...about $2,000 (that's 2 thousand).
 

·
Registered
Joined
·
451 Posts
Mine is doing the same thing. Some info in this forum points toward an internal connector in the unit. I am going to take ir our of the dash and take it apart and look around in it an wiggle/take apart everything and put ti all together again. I just need to get some time. I'll let you know hoe it turns out. If you get to it first let us know!
Oh and Some of my buttons on the bottom of the unit also quit when the screen goes black...
 

·
Registered
Joined
·
1,483 Posts
I also have an 06 mine did this for awhile and then stopped. Not sure why, but it has not happened in over a year. Like a computer, disconnect the + side of your battery and then reboot see if this helps. Beats 2K.
 

·
Registered
Joined
·
451 Posts
Creek Good idea. I'll try that first. Sometimes its easy to overlook the simple things!
 

·
Premium Member
Joined
·
691 Posts
Do all the button work when it happens?
 

·
Registered
Joined
·
451 Posts
Interesting you should ask!
Sometimes they all work, sometimes all the buttons accross the bottom do not, as well as the buttons on the left side behind the steering wheel!
 

·
Premium Member
Joined
·
691 Posts
Same thing happend to mine. I took it to a local shop and they wanted over $600 to fix it. So I got the mygig and adapter instead. It cost more but does have newer maps,touch screen & 20 gig hard drive. I think all said and done it was around $900 -$1000 bucks for everything. Aftermarket might be good for you. Anyway I would not replace a Rec with a Rec. I dont think it is worth it the next one might do the same. Just my 2 cents. Good luck.

Interesting you should ask!
Sometimes they all work, sometimes all the buttons accross the bottom do not, as well as the buttons on the left side behind the steering wheel!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #14
Mine is doing the same thing. Some info in this forum points toward an internal connector in the unit. I am going to take ir our of the dash and take it apart and look around in it an wiggle/take apart everything and put ti all together again. I just need to get some time. I'll let you know hoe it turns out. If you get to it first let us know!
Oh and Some of my buttons on the bottom of the unit also quit when the screen goes black...

did you ever find out anything? i still havent. the buttons on the bottom also dont work for me when the screen goes black, so it sounds like we have the exact same issue :(
 

·
Registered
Joined
·
451 Posts
I tore mine apart last night. With NO luck. I took it out of the dash and tore it down. I saw the internal connector others reference but mine was fine. I disconnected internal cables, wiggled components, etc, but still nothing. I took every fuse out of all three fuse boxes and checked them. Ugh After 3 hours I put it all back together with no success. Even worse, after disconnecting the radio it is on AM radio, and without the bottom row of buttons there is no way to change it!
I don't know what I'm going to do now... I don't really want to spend a ton of cash, but I do a lot of driving for work and to be without a stereo is going to suck. Anybody got an old rec for sale CHEAP?
 

·
Registered
Joined
·
451 Posts
OK,
What do you guys think of this ebay ad to repair the REC unit for $265? Oh Plus $18 shipping plus my $ for shipping. So I guess it will be $300...


I think it is my cheapest way out.

Let me know... I Think it is worth a try....
 

·
Premium Member
Joined
·
691 Posts
I would be careful. That price is only for the screen. If it is only the screen its great. But it might be more to it. like i said i found a place that gave a free estimate. Over $600! http://www.videoservicestop.com/radiorepairs/jeep.htm. And it ended up not to be worth it. Good luck.

OK,
What do you guys think of this ebay ad to repair the REC unit for $265? Oh Plus $18 shipping plus my $ for shipping. So I guess it will be $300...


I think it is my cheapest way out.

Let me know... I Think it is worth a try....
 

·
Registered
Joined
·
451 Posts
I actually asked two places.
Factory Car Radios Direct (CarRadioRepairs.com) and VideoServiceStop.com They both were $600-$650 to repair.
For that price maybe I'll by a used one or two...
 

·
Registered
Joined
·
451 Posts
All right, this is what I did. I bought a used REC from a guy on this forum. I used pieces of his, and pieces of mine. His was from a Chrysler and would display that instead of Jeep, and we just couldn't have that. So obviously even though it was the screen blanking out, the problem is not on that board, it is buried deeper inside the unit. It all works great and I just drove 2.5 hours this morning and it is doing great. Now I have spare parts for it if I need them!
 
1 - 20 of 25 Posts
Top