Jeep Commander Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
I recently got my oil changed and serviced, but before I was doing that, obviously my 3,000 mile ticker had counted down to 0 and was now displaying "service engine/perform maintenance" (forget exactly what it said). But, after driving back from Cinncy and going to work Monday morning I was close to 200 miles over...which isn't bad. My 5.7L shut off on my way to work...talk about scarying you. The cruise kicked off, the accelerator wouldn't work...I put it in Park and it started right up with no problems. Is this just a "safety" feature to keep the owners on their toes? Has anyone else noticed this problem? Let me know.
 

·
Registered
Joined
·
2,473 Posts
No, this is not a safety feature. You either experienced a bump of the key. Or you experienced an issue that has been experienced by several people on the board (although I don't think any had the Hemi).
 

·
Registered
Joined
·
139 Posts
I have exceeded 1400 miles over 3000 on long continuous trips (I use Mobil 1, though) and have had no problems.
 

·
Premium Member
Joined
·
12,578 Posts
I still only have 2,400 on mine but I am getting close to the oil change.

Took it in Monday to ahve the Armor Butler reapplied, they were surprised at the low mileage.
 

·
Registered
Joined
·
2,473 Posts
a49erFootballFan said:
I still only have 2,400 on mine but I am getting close to the oil change.

Took it in Monday to ahve the Armor Butler reapplied, they were surprised at the low mileage.
Wow, you have even less miles than me. I am nearing one year and have just over 5000 miles (most road trip miles). I need to get the paint protectant reapplied this month and am going to go ahead and have the oil changed even though it hasn't reached the miles.
 

·
Registered
Joined
·
2,473 Posts
RedCommander said:
You mean you're going to wax it?
No, the dealer put the AutoMate paint protectant on the vehicle which adds an additional warranty to the paint surface. The additional warranty remains in effect as long as you get it reapplied (at no cost) every 6 months.
 

·
Registered
Joined
·
2,789 Posts
rubicontrail.net said:
No, the dealer put the AutoMate paint protectant on the vehicle which adds an additional warranty to the paint surface. The additional warranty remains in effect as long as you get it reapplied (at no cost) every 6 months.
I had the paint protectant applied also, but I was told to apply it every year and was given a kit to do it myself.
 

·
Premium Member
Joined
·
12,578 Posts
I guess we are the lucky ones, because we take it to the dealer and they wash, wax and detail (even vacuumed) at no additional cost every 6 months as long as we own the vehicle.

Most of my miles were put on when I drove to California to pick up two roof rails from SycoHemi.
 

·
Registered
Joined
·
2,473 Posts
a49erFootballFan said:
I guess we are the lucky ones, because we take it to the dealer and they wash, wax and detail (even vacuumed) at no additional cost every 6 months as long as we own the vehicle.

Most of my miles were put on when I drove to California to pick up two roof rails from SycoHemi.
Yeah, must be it is an AZ thing because I get the detail on mine too. :)

I put most of my miles on a trip around the Grand Canyon/Flagstaff area and then a trip to California to look at (and buy) the pickup. It has been driven to work about 15 or 20 times. It has also made a few trips down towards Tucson and one up to Prescott.
 
1 - 11 of 11 Posts
Top