Jeep Commander Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hello guys,

well and after long waiting I installed an OME 2" HD kit on my 2008 4.7 commander. but after installation and driving for couple of days I am feeling my car strange. I am hearing a lot of clunks and I am getting some vibration sometimes. so I am going to post some pictures of my xk and I would like you guys to advice me:

1- does it look ok, I mean is this the correct height I should get.
2- does the kit change the car geometry.
3- is there any " MUST " modification I should do other wise the lift might affect badly on some parts.
4- does the bushes, and joint balls looks ok.
5- do I must install a rear track bar.
6- I feel my steering strange, does it affect steering ( I checked the toe settings in alignment shop and it was ok)

please advice me with all what you think its important
 

Attachments

·
Registered
Joined
·
1,128 Posts
1) if you didnt get one, you need an alignment.
2) your compression stop isnt seated in the cup of the strut mount, this can cause a clunk noise. Use a screw driver or pry bar to leverage it up in place. I use a few dabs of RTV gasket maker to help hold it in place.
3) the OME instructions are misleading. You need to tighten down the strut nut all the way. Torque should be around 19 ft-lb. If you just tightened it until you saw 7 threads you'll get clunking from the mounts.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
1) if you didnt get one, you need an alignment.
2) your compression stop isnt seated in the cup of the strut mount, this can cause a clunk noise. Use a screw driver or pry bar to leverage it up in place. I use a few dabs of RTV gasket maker to help hold it in place.
3) the OME instructions are misleading. You need to tighten down the strut nut all the way. Torque should be around 19 ft-lb. If you just tightened it until you saw 7 threads you'll get clunking from the mounts.
Thank you matt. thank you for the help
 
1 - 3 of 3 Posts
Top