Jeep Commander Forum banner

3501 - 3520 of 3538 Posts

·
Registered
Joined
·
2 Posts
I just did a 2.5 inch lift in front and 1.5 inch in back on my jeep commander with 2 inch wheel spacers, I have ordered 265/70/17 Toyo A/T tires. Will I need to do the pinch weld mod? The guy I bought the spacers from said it would not need to be done, I will not get any rubbing.
 

·
Super Moderator
Joined
·
5,763 Posts
I just did a 2.5 inch lift in front and 1.5 inch in back on my jeep commander with 2 inch wheel spacers, I have ordered 265/70/17 Toyo A/T tires. Will I need to do the pinch weld mod? The guy I bought the spacers from said it would not need to be done, I will not get any rubbing.
I have a 2 inch Rough Country lift - which is a spacer lift.

I have the exact same tires that you ordered and I have no rubbing whatsoever - and I did not need to do any other modifications for tire clearance.

My rims are 17 x 8 with 5.5 inch back spacing.
 

·
Registered
Joined
·
176 Posts
Just picked up an '06 Limited with the Hemi, tow package, off-road package. Can't wait to dive in and freshen it up.

Quick question: I have the NAV radio with Sirius Satellite which of course is not working since I don't have a subscription for this Jeep. When I tune to SAT the generic Sirius channel shows up but there's no volume (I have satellite in two other Jeeps and even without a subscription that channel will play their promos on the benefits of satellite radio.) Is there a known issue with the satellite antenna? Is there something on the radio I need to check to get volume from the satellite channel?

Thanks in advance - great forum!


Bob
 

·
Registered
Joined
·
309 Posts
Just picked up an '06 Limited with the Hemi, tow package, off-road package. Can't wait to dive in and freshen it up.

Quick question: I have the NAV radio with Sirius Satellite which of course is not working since I don't have a subscription for this Jeep. When I tune to SAT the generic Sirius channel shows up but there's no volume (I have satellite in two other Jeeps and even without a subscription that channel will play their promos on the benefits of satellite radio.) Is there a known issue with the satellite antenna? Is there something on the radio I need to check to get volume from the satellite channel?

Thanks in advance - great forum!


Bob
That is odd. Really, just get the new NAV update disc and that will possibly fix the issue, the radio has had a ton of updates since it came out.

Welcome to the club!

Dave
 

·
Registered
Joined
·
309 Posts

·
Registered
Joined
·
4 Posts
The new guy

2007 JEEP COMMANDER 4.7
ANCHORAGE, ALASKA


Having some issues with the drive train here to see if you guys can help out thanks in advance:|



also here is a video of my issue ****ty vid but you can clearly hear the issue thanks again.
 

·
Super Moderator
Joined
·
5,763 Posts
2007 JEEP COMMANDER 4.7
ANCHORAGE, ALASKA


Having some issues with the drive train here to see if you guys can help out thanks in advance:|
I can't watch videos where I am.

A written description of the problem and some background info on your XK would be more helpful - and I expect you will get more responses that way.

Welcome to the forum.
 

·
Registered
Joined
·
1 Posts
I have an 07 Jeep commander. I am having a problem with the right rear running lights, but the brake light and turn signal work. We have checked fuses and bulbs and those are all good. We have also check to see if voltage is getting back for the running lights. At the connector there is no voltage.

I was wondering if anyone had any suggestions before we start checking the wiring?
 

·
Super Moderator
Joined
·
5,763 Posts
I have an 07 Jeep commander. I am having a problem with the right rear running lights, but the brake light and turn signal work. We have checked fuses and bulbs and those are all good. We have also check to see if voltage is getting back for the running lights. At the connector there is no voltage.

I was wondering if anyone had any suggestions before we start checking the wiring?
If you are talking about the little side running light within the tail light, I had one go bad on me.

The metal tabs inside the socket get very corroded over time, you can try disconnecting your battery and then cleaning the corrosion of the metal tabs in the socket.

The other option is ordering a new tail light harness - you just unplug it from the main wiring harness and it has all 4 sockets wired together, reverse light socket, tailight/brake light socket, turn signal/park light socket and the small side running light socket.

I paid about $80.00 for one tail light harness at the dealership about 2 months ago, it's simple enough to install yourself in about 10 minutes or so.
 

·
Registered
Joined
·
2 Posts
newbie

I have a 2006 4x4, white and pretty much stock. would like to some modifications, but not really mechanic savvy. I am in Austin, TX. will post pics soon...
 

·
Super Moderator
Joined
·
5,763 Posts
2007 Blue sport 3.7L
Mexico. Just 83k miles on her!
Colerix said:
This October im getting a 07 Commander Sport, just wanted to let you know im loving the work you are doing on yours, im pretty sure ill be coming back for some inspiration.

Its gonna be my first car soo im pretty excited and really wanting to take care of it, its going to be my little blue baby. (The color is exactly like yours)
I was wondering if / when you were going to finally show up Colerix.

Welcome back and best of luck with that beautiful blue XK.
 
3501 - 3520 of 3538 Posts
Top