Jeep Commander Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I actually posted this just before but I'm reposting because I think I put it in the wrong category.

My jeep was running perfectly fine until a few weeks ago when I suddenly got a check engine light when I turned it on and immediately started having issues that very moment. I checked the code with the key trick and got a P0700 code but nothing else.

It will almost stall or stall completely when I come to a stop. Not always though and it's worse on certain angles. For example, I have to park on a slant in front of my house so the vehicle is tilted to the left. I stall out about half the time I pull into the spot and stop to reverse for adjustment, although sometimes it stalls here before I even completely stop.

The transmission fluid is fine so that isn't the issue.

I'm hoping someone may have some ideas on things I can try to do myself before paying for a mechanic. Any help is very much appreciated
 

·
Registered
Joined
·
5 Posts
Not sure what the P0700 code is & not sure if this will help you. I have 06, 4.7 with 260K miles. At one point engine would not idle, ran rough,..... I replaced the IAC (idle air control valve) and it solved issue. Very easy to replace.
 

·
Registered
Joined
·
1,552 Posts
I have read that using other than OEM filters in the transmission can cause problems. You say the fluid is good, but you might want to check on filters with whomever changed the fluid.
 
1 - 3 of 3 Posts
Top