Jeep Commander Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 · (Edited)
:mad: :mad: Well 16k mi and sad to say and my 06 is getting a new rear end. Dealer replaced the pinion seal. 33mi later on the interstate and seemed like a down shift then a vibration started. I pulled over right away. I got out and noticed smoke coming from the rear end area. I got under my jeep and the rear end was smoking!!! I waited 15 min then pulled the rubber fill cover off the rear end. NO OIL. WTF. The dealer were I had the pinion seal fixed gave me a liberty loaner. Nice trade. huh. Oh yeah that damn wind noise is back. Its driving me nuts. I cant stand noises I have no Idea and noway to control. :confused: I love my jeep even after the frustrations its causing.
Its worth it right?
crazy thing was while sitting on the side of interstate atleast 10 commanders drove by everyone of them hit the brakes as if they were shocked seeing a 06 on a flatbed. Oh yeah my 8 1/2 prego wife standing there aswell. I had the flatbed driver drop my truck off infront of sales instead of service. lol that was. The owner of the dealer came out and asked to have the truck dropped off around back. A loaner wasn't even in question just get that truck around back. chrysler "ASS"ISTANCE wouldn't tow my truck home just to nearest dealer. No rental aswell. Nice customer service chrysler.
I paid the towing to dealer that just did rear seal service. I'm not going to post dealer name unless they decide to say not there fault. :eek:
 

·
Registered
Joined
·
2,473 Posts
Yeah Chrysler Roadside Assistance will get you to your dealer, just not your dealer of choice. You need AAA for that. When the starter on my Cherokee died, AAA towed it past three other Jeep dealerships to take mine to the dealership I wanted to go to.

Are you sure the geniuses at the dealership even put the oil back in the differntial when they replaced the seal?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
yep no oil. none around the rear end like it would be if leaked out. They pressure washed the rear af the truck because of the prior leak. still clean. I have towing on my insurance so thats not the issue. no rental avaiable after 12noon was my problem. being towed to a dealer in a town where I didn't live sucks. my 8 1/2 month pregnant wife wasn't even going there. Im going to let them tell me what they think happened first then I will inform them I removed the rubber inspection/fill hole cover. No oil in the rear end. Im sure they will have DC replace the rear end without disclosing they forgot to put oil in the rear end. big oops.Will update next week. AAA+
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
:eek: :eek: new ring and pinion gear and yes dc replaced. They almost tried to hand me a rental bill. Yeh right I'm not paying for rental for your screw up. They had to get my rental agreement and go thru it and to there surprise there wasn't a rental agreement. The owner of the dealership handed me the keys to a liberty and said they will be intouch. Hence no rental agreement. Its all good though rear end is fine now with no leak. now to just get that damn wind noise fixed. :confused: next dealer please;)
 

·
Registered
Joined
·
122 Posts
I hope your dealer was not a "5-start rated" dealer... Those ratings are a joke.

I'm sure you'll be giving them 1's and 0's out of 5 when you get your survey in the mail for services rendered. (If they even dare ask you about the quality of their service).

Is it me?? or are 4 out of every 5 Jeep dealers out there really pathetic in terms of customer service????!!!!
 

·
Registered
Joined
·
15 Posts
I want to know why a brand new 06 with so few miles on it needed a new pinion seal in the first place. Was there a recall? If not, what symptoms would I look for? I feel your pain, mines at the dealer now and I dont know what the problem is yet. I posted a seperate post on it just now.
 

·
Registered
Joined
·
2,473 Posts
princess said:
I want to know why a brand new 06 with so few miles on it needed a new pinion seal in the first place. Was there a recall? If not, what symptoms would I look for? I feel your pain, mines at the dealer now and I dont know what the problem is yet. I posted a seperate post on it just now.
There is no TSB for such an issue. I believe that if you have a pinion seal leak you would see differential fluid leaking from near the front of the rear differential.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #8 ·
Your rear end has clear synthetic oil in it. The dealer insisted the clear fluid I was seeing was my rear evap unit for the rear ac. Ok water doesn't burn!!! My exhaust has a build up of burned oil on it. This was the only way I could convince my dealer there was a problem. I had to call the service manager to get this problem resolved. The service writer wrote check rear ac leak even after telling them it was the rear end. As for symptoms I noticed a vibration and a burnt oil smell from the rear end. Also check the inside of your rims for oil leaking from axle seals. Good luck. I have 500 miles since repair done and everything all good. except that damn windshield noise.
 
1 - 8 of 8 Posts
Top