Jeep Commander Forum banner

21 - 32 of 32 Posts

·
Registered
Joined
·
84 Posts
Awesome, looking forward to reading about what you put together.
It turned into a pain in butt of a job.

made great progress with the right kit, i used -

Autoleads PC5-121 - Jeep Cherokee, Grand Cherokee, Wrangler ISO Aerial Adaptor (PC5-121)
and
Connects2 CTSJP00C Jeep Commander, Compass, Grand Cherokee Steering Control Stalk Adaptor
- Additional Stereo Patch Lead: Free CTMULTILEAD.2 (CTSJP00C)
from dynamicsounds.co.uk>

got power, steering wheel controls, DVD, USB, SatNAv,, Radio etc with very good volume via the inbuilt amp - But no voice from satnav or on handsfree phone calls - other party could here me though.

spent a day and a half trying to sort that out - including several hours on the phone to pioneer - who were also stumped for a solution. kept saying something about it wont work (ever) due to the inbuilt amp reveresing polarity and messing up the mobile and satnav voice!!

had a look around on loads of websites and forums and solutions ranged from deleting google apps from phone (really?) to switching from android to I-Phone. tried 4 android handsets and an I-phone - no success.

Then a light bulb moment (my son did anyway) - if its a speaker polarity issue, swop the speakers around. did a quick google and found -

(my great thanks and acknowledgement to the original poster of this solution)

Swapped the connectors as suggested in the video (slight colour differance on my unit) and hey presto!! works like a dream.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #22
It turned into a pain in butt of a job.



made great progress with the right kit, i used -



Autoleads PC5-121 - Jeep Cherokee, Grand Cherokee, Wrangler ISO Aerial Adaptor (PC5-121)

and

Connects2 CTSJP00C Jeep Commander, Compass, Grand Cherokee Steering Control Stalk Adaptor

- Additional Stereo Patch Lead: Free CTMULTILEAD.2 (CTSJP00C)

from dynamicsounds.co.uk>



got power, steering wheel controls, DVD, USB, SatNAv,, Radio etc with very good volume via the inbuilt amp - But no voice from satnav or on handsfree phone calls - other party could here me though.



spent a day and a half trying to sort that out - including several hours on the phone to pioneer - who were also stumped for a solution. kept saying something about it wont work (ever) due to the inbuilt amp reveresing polarity and messing up the mobile and satnav voice!!



had a look around on loads of websites and forums and solutions ranged from deleting google apps from phone (really?) to switching from android to I-Phone. tried 4 android handsets and an I-phone - no success.



Then a light bulb moment (my son did anyway) - if its a speaker polarity issue, swop the speakers around. did a quick google and found -



https://www.youtube.com/watch?v=P87IMOoDlsA (my great thanks and acknowledgement to the original poster of this solution)



Swapped the connectors as suggested in the video (slight colour differance on my unit) and hey presto!! works like a dream.

Good to hear after a long battle you won! Do you have the rear dvd sound working through your speakers? That’s one thing that I didn’t get working yet.


Sent from my iPad using Tapatalk
 

·
Super Moderator
Joined
·
5,769 Posts
It turned into a pain in butt of a job.

Then a light bulb moment (my son did anyway) - if its a speaker polarity issue, swop the speakers around. did a quick google and found -

https://www.youtube.com/watch?v=P87IMOoDlsA (my great thanks and acknowledgement to the original poster of this solution)

Swapped the connectors as suggested in the video (slight colour differance on my unit) and hey presto!! works like a dream.
Sounds like your perseverance paid off @CP07; That's great, glad to hear it.
 

·
Registered
Joined
·
131 Posts
It turned into a pain in butt of a job.

made great progress with the right kit, i used -

Autoleads PC5-121 - Jeep Cherokee, Grand Cherokee, Wrangler ISO Aerial Adaptor (PC5-121)
and
Connects2 CTSJP00C Jeep Commander, Compass, Grand Cherokee Steering Control Stalk Adaptor
- Additional Stereo Patch Lead: Free CTMULTILEAD.2 (CTSJP00C)
from dynamicsounds.co.uk>

got power, steering wheel controls, DVD, USB, SatNAv,, Radio etc with very good volume via the inbuilt amp - But no voice from satnav or on handsfree phone calls - other party could here me though.

spent a day and a half trying to sort that out - including several hours on the phone to pioneer - who were also stumped for a solution. kept saying something about it wont work (ever) due to the inbuilt amp reveresing polarity and messing up the mobile and satnav voice!!

had a look around on loads of websites and forums and solutions ranged from deleting google apps from phone (really?) to switching from android to I-Phone. tried 4 android handsets and an I-phone - no success.

Then a light bulb moment (my son did anyway) - if its a speaker polarity issue, swop the speakers around. did a quick google and found -

https://www.youtube.com/watch?v=P87IMOoDlsA (my great thanks and acknowledgement to the original poster of this solution)

Swapped the connectors as suggested in the video (slight colour differance on my unit) and hey presto!! works like a dream.

This is exactly what I kept saying in all my other posts here, those wires you reversed are the fronts and rears. Whites/Greys are fronts, Purple/Green are rears. That's not a polarity reverse, it's just signal routing. The Nav and BT are only output to the front speakers from the headunit, the amp only takes input from the rear speaker lines.
 

·
Registered
Joined
·
84 Posts
This is exactly what I kept saying in all my other posts here, those wires you reversed are the fronts and rears. Whites/Greys are fronts, Purple/Green are rears. That's not a polarity reverse, it's just signal routing. The Nav and BT are only output to the front speakers from the headunit, the amp only takes input from the rear speaker lines.
A fair point. it was counter intuitive though to start swaping things around, not wanting to blow anything in the unit and void the warranty.

A major part of my problem was that the original installer hadn't made any proviso for power to the amp in the first place at all -so from that point on it was an uphill battle - until i dispensed with him and replaced the harnes adapter he had used.

Sorry i didnt pick up on your point earler. no offence intended.
 

·
Registered
Joined
·
131 Posts
A fair point. it was counter intuitive though to start swaping things around, not wanting to blow anything in the unit and void the warranty.

A major part of my problem was that the original installer hadn't made any proviso for power to the amp in the first place at all -so from that point on it was an uphill battle - until i dispensed with him and replaced the harnes adapter he had used.

Sorry i didnt pick up on your point earler. no offence intended.

ya, no worries! just trying to help avoid others' headaches before they happen!


you won't blow up anything with stereo wiring as long as you keep the powers (red: constant and yellow: switched) and ground proper!
 

·
Registered
Joined
·
43 Posts
I just installed the Pioneer MVH-1400NEX in my Commander. The factory Nav radio was dead. I wanted Apple Carplay as well as Android Auto which this unit supports both. I haven't tried the Android Auto but the Apple Carplay works great. I also wanted to add a backup camera which I installed in the lift gate to the left of the license plate. Programming the iDatalink was relatively easy following the instructions from Maestro's website. It was time consuming connecting the Pioneer harness to the HRN-RR-CH2 harness (you have to splice them together) but it was simple again following the instruction from Maestro. Also routing the backup camera harness through the lift gate and along the overhead to the dash took some time and patience. I was able to feed the cable through the lift gate wire boot so everything should stay dry. The only hole I had to drill was in the chrome piece on the lift gate that houses the latch and license plate lights. The camera was mounted to the underside of it.
I didn't use the OBDII connection as I have a Trail Dash 2 but all you have to do is connect to the OBDII with the supplied connector and you can see all the gauges and tire pressures on the radio display. I did keep my factory amp and speakers and have full balance and fade control. It sounds fantastic! The rear DVD does not play to the radio screen nor does the sound come through the speakers which would have been nice, but I'll pick up some IR headphones which will probably work better in the long run.

I ordered everything from Amazon. The total install was under $500.00. Components I used:

Pioneer MVH-1400NEX
https://www.amazon.com/dp/B07951J34N/ref=cm_sw_em_r_mt_dp_U_DGpqDbZ29DA2W
Maestro HRN-RR-CH2 Plug and Play T-Harness for CH2 Chrysler, Dodge, Jeep Vehicles;
https://www.amazon.com/dp/B01FYCWAR4/ref=cm_sw_em_r_mt_dp_U_zNpqDbT6FGZ3R
Maestro ADS-MRR Universal Radio Replacement and Steering Wheel Interface
https://www.amazon.com/dp/B00E4W1644/ref=cm_sw_em_r_mt_dp_U_VJpqDb7STCTRD
Metra 99-6510 Chry/Dodge/Jeep with NAV 04-UP Dash Kit
https://www.amazon.com/dp/B000K52D0K/ref=cm_sw_em_r_mt_dp_U_cOpqDbXYVQNKV
Metra 40-CR10 Chrysler 2001-Up Car Antenna Adapter
https://www.amazon.com/dp/B0002BEQNE/ref=cm_sw_em_r_mt_dp_U_ZQpqDbRPPPVWF
NATIKA Backup Rear View Camera Chrome,IP69K Waterproof Great Night Vision HD and Super Wide Angle Metal OEM Style Chrome Reverse Rear View Backup Camera for Cars Pickup Trucks SUVs RVs Vans (Chrome)
https://www.amazon.com/dp/B07HNFWSQN/ref=cm_sw_em_r_mt_dp_U_IRpqDbZ5YB2CA

I'll post pictures soon. Hopefully this help someone trying to decide on a radio upgrade. I couldn't be happier with the look and function of all the components.
I purchased the same set up and can't for the life of me get the back up camera to work. I'm curious as to how you set up the wiring? Also, the harness I have doesn't seem to like the red ACC wire. I am wiring red to yellow just to get power to the head unit. Which means I will have to manually power it off every time I get out of the car.... I know I'm going to regret that. Any thoughts?
 

·
Registered
Joined
·
131 Posts
I purchased the same set up and can't for the life of me get the back up camera to work. I'm curious as to how you set up the wiring? Also, the harness I have doesn't seem to like the red ACC wire. I am wiring red to yellow just to get power to the head unit. Which means I will have to manually power it off every time I get out of the car.... I know I'm going to regret that. Any thoughts?
Could be an issue with the iDatalink unit's firmware. I'm not personally familiar with this set up, but I am familiar with iDatalink and Maestro units. You usually have to flash the appropriate firmware into the brain. Not always, sometimes they come ready to go, but sometimes you need to flash a different version. Like it shipped with a default Chrysler version that works on most of the cars, like CH2.1 but needs an altered CH2.2 for the Jeeps. I'm making these version numbers up, but I think you get what I'm trying to say. Check the iDatalink website- it'll send you to a PDF of detailed instructions. THOROUGHLY read the instructions for your exact year model and the part numbers for the harness(es) and the head unit you have. Sometimes your answer is in one line of text easily read over.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #30
I have to pull my radio out to finish installing the day mount USB port, but I'm not sure when I'll get to that. I really can't remember having any issues with the power wires. I believe I connected the camera to the red radio power wire.
I'll try to look at it this weekend while digesting turkey and pumpkin pie.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
I'm getting ready to install a Pioneer MVH-1400 into a 2006 Limited as well. Using the Maestro RR and the meastro harness, will I still get all the chimes, beeps, backup beeps, etc? I'm not sure if that has anything to do with now-dead OEM nav head unit I have (the radio still works and I get all the various chimes but everything else seems dead on it) or if that's a seperate system.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #32
I'm getting ready to install a Pioneer MVH-1400 into a 2006 Limited as well. Using the Maestro RR and the meastro harness, will I still get all the chimes, beeps, backup beeps, etc? I'm not sure if that has anything to do with now-dead OEM nav head unit I have (the radio still works and I get all the various chimes but everything else seems dead on it) or if that's a seperate system.
It all works on mine.


Sent from my iPhone using Tapatalk
 
21 - 32 of 32 Posts
Top