Jeep Commander Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
343 Posts
Discussion Starter #1
Has anyone tried to update their diablo sport preditor. I just got mine and cannot get the crom file to read. I keep getting a "file missing or corrupt" and diablo is no help.
 

·
Registered
Joined
·
2,194 Posts

·
Registered
Joined
·
362 Posts
I had the U7137 for my 2010. I could not use the speedometer calibrator and their tech support was useless.

The other features were pointless or non-functional.

The device is a FAIL for a 2010 Hemi XK.

I sent it back.
 

·
Registered
Joined
·
343 Posts
Discussion Starter #4
Update.... She's All Better. Very, time consuming and frustrating. Tech support was ehhhh.


So pulled it out of the box, plugged it in and first thing it says is you must update it. Ok so I download all my files and nothing. My issue was, you would begin to download the update, and it would make it through stage 1, but would stop and sit at stage 2. I called the techs and used 235 minutes on my cell phone to figure it out. First they said my files were bad, ok deleted and re-downloaded them. Nope. Ok, so they sent me the file in e-mail. Nope. Ok, so they send me the older file that they know works and Nope. Try re-installing the downloader program, still nothing.

Off the wall answer. Its on your end, nothing to do with the programer. Swithced pc's in my home. Same problem. Called back, ok the cable you paid $40 bucks for through us is bad. Ok so quick trip to Radio Shack and their cable was $50. Still nothing. Called back, its your network. Ok so I ran to work and hooked everything up, and still nothing. Called them back and demanded they send me a new one, overnighted. Thats when they started working quicker. The one guy walked me through, step by step, (felt very stupid) and still nothing. He goes "let me talk to the devolpers". Comes back about 20 minutes later with the solution. Apparently theres an erorr between bits 2 and 3 in the file. So when it started to update, it would say bit 2 of xxxxxx, right after that, I closed the uploader and begain the process of re loading the file and it worked. Wow I couldnt be happier.

I spent from 7pm last night to 11pm, then today from 1pm to 6pm. Very frustrated, but worth it. It gets up and goes alot better. Shifts alot harder too. Only issue is when in wide open throttel, it will not shift from 1st to 2nd. So I reinstalled the tune into my vehicle and I'll see tommorow if shes good.
 

·
Registered
Joined
·
362 Posts
I don't know how your story will end, but I had purchased mine in May. The software the had for the 2010 Hemi was horrible. Keep all of the packing in case you need to send it back for good...

I bought it to adjust my speedometer and figured it would be cool to tune the truck and maybe help out the pathetic fuel economy. Well, the speedometer adjustment would bomb out. I went and joined the Preditor forum at the company's site and found out I was not alone...

See http://www.diablosport.com/index.php?name=PNphpBB2&file=viewtopic&t=21762&highlight= and http://www.diablosport.com/index.php?name=PNphpBB2&file=viewtopic&t=22159&highlight= .

Anyway, I figured let's try out the other stuff it can do. The 89 and 87 tunes made no significant improvements to the OEM program. The code reader did not work properly.

The whole thing was a bummer...

I say buyer beware... maybe the 2007 - 2009 programmer works true to form but the 2010 is definitely a FAIL.

Chuck
 
1 - 5 of 5 Posts
Top