Jeep Commander Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
hey i just bought new housings for my 06 commander and they came with 6k hids and i did not do the relay but just did it normal with the ballast that comes with it and now they dont work at times like they did not work when i put my lights in the auto setting then if i wasnt in the auto they would come on or if i hit the unlock on the key fob they would blink but then now turn on when i turn the headlights on but if i unplug the main connector and reconnect it they would work again.
im not too shabby when it comes to electrical problems so i knew this woujld be the best place to ask so please im all ears
thanks
chris
 

·
Registered
Joined
·
206 Posts
I doubt that the canbus electrical system on the Commander will work correctly with HID lights. The load sensing required to work with the canbus is probably confusing the PCM. Just a guess but I would think you would need to isolate the HID's using a relay with a load resistor for the can bus system to work.
 

·
Registered
Joined
·
29 Posts
hey i just bought new housings for my 06 commander and they came with 6k hids and i did not do the relay but just did it normal with the ballast that comes with it and now they dont work at times like they did not work when i put my lights in the auto setting then if i wasnt in the auto they would come on or if i hit the unlock on the key fob they would blink but then now turn on when i turn the headlights on but if i unplug the main connector and reconnect it they would work again.
im not too shabby when it comes to electrical problems so i knew this woujld be the best place to ask so please im all ears
thanks
chris

@commanderlife06 I had the same issue as you, then I switched over to two different sets of LED 8000k lights, the first set also had an issue with staying on and did a flickering type of thing when the lights were all the way off. They only shut off when the XK was off. One light would be on and one would go off randomly while driving. After carefully checking the wiring and going back to square one, The lights were faulty. Unsure of the faulty brand.

The new ones which are a brand called: Stark Phantom 8000K LED Lightbulbs WORK Perfectly!!!!!

These just plug directly in. They are the bright white lights I am assuming you are looking for.

The HID Set is a waste of money....

In the first attached photo are the black housing headlights that came in the mail. (1)
In the second photo, the HID Lights are installed, lights are fully on, but they are not illuminated, the fog lights work (2)
In the third photo, the HID Light kit that came with the black housing headlamps (3)
In the fourth photo, Jeep Vinyl Wrapped, has the Stark 8k LED bulbs in them Working (4)
 

Attachments

·
Registered
Joined
·
7 Posts
Discussion Starter #5
thats what ive been told now im going to try the relays first but i may still go with the led bulbs for the long haul but thank yall for the help
 

·
Registered
Joined
·
338 Posts
I never had a problem with my $50 HIDs, except radio reception was a little worse. However, I don't have auto dimming, or auto on or any of that......
 

·
Registered
Joined
·
23 Posts
iim having the same issue, i brought error cancelling modules that go in line with the HID plugs but still nothing, im deducting that its a cheap set of ballast
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
I just tried to look for the relays at auto zone but they looked at me like I was stupid so for everyone who has bought the relays where did you buy them or the details on where to get them please and thank you
 

·
Registered
Joined
·
303 Posts
I just tried to look for the relays at auto zone but they looked at me like I was stupid so for everyone who has bought the relays where did you buy them or the details on where to get them please and thank you
You just need a relay that has a 12v coil and enough amps to carry the load of the lights. Essentially you are isolating the load from the system instead of the load going through the CANBUS system.



Similar to this:

https://www.homedepot.com/p/VIAIR-40-Amp-Relay-93940/202948551?cm_mmc=Shopping|THD|google|&mid=sGGzTBmKX|dc_mtid_8903tb925190_pcrid_111416414825_pkw__pmt__product_202948551_slid_&gclid=CjwKCAiA8P_TBRA9EiwAJrpHMzi9O0_q2uHKMEenug4N4Y0Ge9Ira3k1bvC6kZ8buT1ujqTeNy52HhoC1lMQAvD_BwE
 

Attachments

·
Registered
Joined
·
7 Posts
Discussion Starter #11
im sorry but anything electrical confuses the crap out of me. I found one at Napa but it don't look like the one you show and im running out of time to fix this since its my wife's jeep and I want everything to work so I don't have to worry about her driving at night. But for my sake is there anyway to have an in depth how to with pictures and everything for me please lol like I said before this is my worst category when it comes to having to fix something. Thanks again

chris
 

·
Registered
Joined
·
303 Posts
im sorry but anything electrical confuses the crap out of me. I found one at Napa but it don't look like the one you show and im running out of time to fix this since its my wife's jeep and I want everything to work so I don't have to worry about her driving at night. But for my sake is there anyway to have an in depth how to with pictures and everything for me please lol like I said before this is my worst category when it comes to having to fix something. Thanks again

chris
Quick search found this...



Sent from my Note 8 using Tapatalk
 
1 - 12 of 12 Posts
Top