Jeep Commander Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all. I am a proud new owner of a 2006 commander with 22,000 miles. It's a limited with the 5.7 and quadrants drive II. Here comes the concerned part. I was driving down the road at about 50 and all the interior lights/display and engine shut off. The only thing left on was the nag screen. I costed to the side of the road, put it in park and it started right back up. Any ideas would be appreciated. I do have a warranty and was wondering if there are any other things I should look for or have the dealer update. Thanks for any input.
Btw I love he way this vehicle drives, a little different then my 89 Cherokee!
 

·
Registered
Joined
·
1 Posts
My 07 limited would stall at idling,never did it while driving. Threw code and Dealer changed the ignition switch about six months ago and its been working fine. Do a quick search on stalling and youll find out your not alone.
 

·
Registered
Joined
·
5,610 Posts
turn your ignition key over.

when i first got mine this happened a couple times. the keys hanging down off the tab would bump my knee and shut the engine off.
 

·
Registered
Joined
·
130 Posts
Never had the issue myself... First thing that comes to mind is the microchip in the key itself.... Then I would consider just checking the fuses and minor stuff... Also, Clean out the throttle body. Its fairly simple to do the 3 and 4th suggestions.... Good luck. Also, have someone run the codes for sure!
 
1 - 6 of 6 Posts
Top