Jeep Commander Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter #1
Has anyone replaced the stock 5.7 radiator with a larger capacity unit and/or a 190* thermostat? If so, what were the results and where did you find the radiator. I live in FLA and have noticed my temps starting to climb into the low 220s in stop/go traffic. I dont remember running this hot prior to this year. Btw, the water pump is fairly new and a mopar. And there isn't a bubble in the system. I'll admit, my current thermostat could be the culprit. Regardless, at 136k miles, i think I'd like to replace the original radiator anyway. And while doing so, go with some extra cooling components to avoid excessive heat and a possible valve seat drop.

Ps - I found a thread or two on this subject in the forum that seemed to lack a conclusion.

Thanks for the help.
 

·
Registered
Joined
·
94 Posts
Discussion Starter #2
 

·
Registered
Joined
·
94 Posts
Discussion Starter #3
Anybody? Bueller?... LOL
 

·
Registered
Joined
·
94 Posts
Discussion Starter #4
Update: so I heard back from my mechanic regarding the above listed issues. Seems the thermostat is the issue with the collant temps. And they're going to install a larger trans radiator. Hopefully this corrects the issues. More after i test it a bit in real world conditions.
 
  • Like
Reactions: Big Blue

·
Registered
Joined
·
94 Posts
Discussion Starter #6
Yeah, I gathered as much. LOL No problem. Looking forward to seeing the results of the new 180 or 190* thermostat and larger trans cooler. Gotta catch these heat related issues early... valve seat repair ain't pretty. :oops:
 
  • Like
Reactions: jess.schwind

·
Administrator
Joined
·
6,824 Posts
Yeah, I gathered as much. LOL No problem. Looking forward to seeing the results of the new 180 or 190* thermostat and larger trans cooler. Gotta catch these heat related issues early... valve seat repair ain't pretty. :oops:
I'd be curious to know, if you see a noticeable difference in your normal running temp, after you finish this upgrade.
 

·
Registered
Joined
·
94 Posts
Discussion Starter #8
I get the beast back in a couple of days... I'll post the results.
 

·
Registered
Joined
·
15 Posts
I just replaced my radiator along with the 180 thermostat. Runs so much better and so much cooler. I was having all sorts of issues prior. Don’t wait till 240k like I did.


Sent from my iPad using Tapatalk Pro
 

·
Administrator
Joined
·
6,824 Posts
I just replaced my radiator along with the 180 thermostat. Runs so much better and so much cooler. I was having all sorts of issues prior. Don’t wait till 240k like I did.


Sent from my iPad using Tapatalk Pro
What brand radiator did you go with?
 

·
Registered
Joined
·
94 Posts
Discussion Starter #12
I went with a 180 also. I was able to test it out yesterday. Amazing how cool it keeps the fluid even in FLA stop/go traffic! I've not been able to get temps above 197... and I tried to push it. As far as the trans fluid cooler, I was not happy with the temps with the first auxiliary radiator (too small... temps were a bit hot), so Im having a bigger one installed. I hope to get it back tomorrow with following results to report.
 
  • Like
Reactions: Big Blue

·
Administrator
Joined
·
6,824 Posts
I went with a 180 also. I was able to test it out yesterday. Amazing how cool it keeps the fluid even in FLA stop/go traffic! I've not been able to get temps above 197... and I tried to push it. As far as the trans fluid cooler, I was not happy with the temps with the first auxiliary radiator (too small... temps were a bit hot), so Im having a bigger one installed. I hope to get it back tomorrow with following results to report.
I'll be interested to hear your results.
 

·
Registered
Joined
·
94 Posts
Discussion Starter #14
Same here. Lol. We're trying a couple different things for the trans cooler at this point. Hopefully i get it back tomorrow or wednesday.
 

·
Registered
Joined
·
15 Posts
Blue - I replaced with the Mopar radiator. The thermostat is the the key going forward especially for warmer climates.


Sent from my iPad using Tapatalk Pro
 

·
Registered
Joined
·
94 Posts
Discussion Starter #16
So... looks like i might need a new trans fluid pump as we diagnosed a lack of circulation today. Certainly would account for the high temps. I'll know more on monday.
 

·
Registered
Joined
·
94 Posts
Discussion Starter #18
So the new 180* thermostat is awesome... i rarely breach the 200* mark anymore. Also, the issue with the transmission temps was caused by blockage in the cooling lines. Little to no circulation. Thats now been cleared and I'm also benefitting from extra cooling from the secondary external cooler/radiator that was installed.
 
  • Like
Reactions: Big Blue

·
Administrator
Joined
·
6,824 Posts
So the new 180* thermostat is awesome... i rarely breach the 200* mark anymore. Also, the issue with the transmission temps was caused by blockage in the cooling lines. Little to no circulation. Thats now been cleared and I'm also benefitting from extra cooling from the secondary external cooler/radiator that was installed.
Any particular brand of thermostat that you used?
 

·
Registered
Joined
·
94 Posts
Discussion Starter #20
I believe a Stant thermostat was used.
 
  • Like
Reactions: g_ster
1 - 20 of 26 Posts
Top