Jeep Commander Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all,

I have been doing some research on this but have still yet to come across and exact thread.

I have a 2007 Jeep Commander with the Boston Acoustics system in it, has the amp in the rear drivers side panel, and my radio will power on but absolutely no sound comes out of speakers. The amp has blown before, so the previous owner said, but the replacement amp was a factory Amplifier when replaced (2 years ago), could it have blown again? I have checked the Green 30 fuse under the steering wheel column and that is OK. There is also no moisture in the rear panel where the amp is located. What could be causing this?

Do you guys have any ideas on how to solve this issue from occurring again?

Thank you
 

·
Super Moderator
Joined
·
14,939 Posts
I have had the same issue recently. I pulled the fuse and it did not have a break in it but it did have have some dark places on the metal that plugs into the fuse box. I replaced the fuse and still nothing, so I guess a new amp will be next.
 

·
Super Moderator
Joined
·
5,783 Posts
My amplifier hasn't given me any problems yet.

Hopefully, it will stay that way.

I've already replaced the radio twice.

Once due to a bad display that wouldn't display back-up camera video (Yes - I replaced the back-up camera first).

About a month later, the CD player in that radio started skipping, so, I had it replaced a second time - which the dealership did at no further cost to me.
 

·
Registered
Joined
·
68 Posts
i replaced my amp today with a kicker mopar upgrade... not sure how much of a difference it made over the BA amp.. but it certainly fixed the speakers not working on one side...

could not find any indicators that water had leaked into the amp..

i will put some pictures up..

it is a pain in the ass.. you have to remove the big bottom panel and the top panel.. both are pains in the butt... someone worked behind the panels before. because instead of taking them off.. they broke, cracked, cut their way into it to save time...

i have no idea why people think it is ok to cut into someone else's car.. to save them time?... greedy bastards. mind boggling.. i tell you.
 

·
Registered
Joined
·
3 Posts
i replaced my amp today with a kicker mopar upgrade... not sure how much of a difference it made over the BA amp.. but it certainly fixed the speakers not working on one side...

could not find any indicators that water had leaked into the amp..

i will put some pictures up..

it is a pain in the ass.. you have to remove the big bottom panel and the top panel.. both are pains in the butt... someone worked behind the panels before. because instead of taking them off.. they broke, cracked, cut their way into it to save time...

i have no idea why people think it is ok to cut into someone else's car.. to save them time?... greedy bastards. mind boggling.. i tell you.
Where is the BA AMP located on a 2007?
 

·
Super Moderator
Joined
·
14,939 Posts
Where is the BA AMP located on a 2007?
The amp is located behind the driver's side panel in the cargo (3rd row seat) area.

.

.
 
1 - 6 of 6 Posts
Top