Jeep Commander Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey Guys, got a 2006 Commander 3.7 with 305k and its still running pretty good. I recently gave her a tuneup after experiencing some rough idle and poor fuel economy. Its running much better after the new plugs and oil change. Here are my 2 issues. The temp gauge goes up about 1/3 of the way and the heat doesn't get hot until driving for 1/2 hour or so. The temp gauge never gets past 1/3 even after driving for a long period of time. Its freezing up he in the NE but the Jeep ran cooler than normal after flushing the cooling system and swapping out the thermostat back in the summer. I do notice the interior windows fog up when putting on the heat. My other issue is poor fuel economy. Even when I baby it I'm lucky to get 13 mpg.
 

·
Registered
Joined
·
487 Posts
You may have a faulty thermostat. If stuck open, it can cause an engine to run cooler for awhile, and a cool running engine will never reach ideal power and therefore will get poor mileage.
 

·
Registered
Joined
·
3,037 Posts
Concur with the thermostat, it controls the flow of the coolant to the radiator to maintain the engine temp. Are you sure you got the correct temperature thermostat when you replaced it? Regardless, they are cheap, they can go bad in a short time and stick open.

Cold windows will have humidity in the air condense on the cold surface, i.e. fogging windows. Note, when you turn on defrost, it engages the air conditioning to remove humidity from the air and stop the fogging of the windows.

That is why you have combination air flow settings on the environmental controls, if windows are fogging while you're using the heat, then switch to defrost/panel or defrost/feet, to stop the fogging.

Low mileage, the engine running cold, under a certain temp will run richer, hurting mileage. But depending on your driving habit and conditions, but 13mpg in a Commander, even a v6 is NOT out of the ordinary.

Winter, mileage usually drops for all vehicles, most areas switch to a winter formulation of gasoline that has more oxygenation in it, reducing mileage and your engine start much colder and take much longer to warm up each time you drive, which the A/F ratio is much richer for a colder engine and doesn't get back to normal before the engine gets above a certain temp, somewhat before full operating temp.
 

·
Registered
Joined
·
213 Posts
If you have replaced the thermostat with a non-oem type this could be your problem. I have seen two failures of brand new Murray thermostats in the last couple of years that caused similar over cooling problems.
 
1 - 5 of 5 Posts
Top