Jeep Commander Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Does anyone know for sure where the antenna is located for Sirius on a 2007 Commander ? Is it anywhere near the windshield ?

I had the windshield replaced before I took delivery of a 2007 and the Sirius keeps reading NO RECEPTION and stuck on channel 184.

I wanted to know if it was related. In either case, we are going back to the dealer tommorow.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
Sirius Stuck on 184 NO SIGNAL ERROR

Sirius says it is supposed to work on 184 without service. Does anyone know if the windshield could have caused it some way ? Is the Sirius supposed to read CH 184 NO SIGNAL and remain stuck ?

Thank you for the picture of the antenna location.
 

·
Moderator
Joined
·
1,993 Posts
Sirius says it is supposed to work on 184 without service. Does anyone know if the windshield could have caused it some way ? Is the Sirius supposed to read CH 184 NO SIGNAL and remain stuck ?

Thank you for the picture of the antenna location.
I was looking at the cable routing and stuff from the antenna. the receiver is in the back passenger side behind the panel. I could not see where the windshield comes into play with the system. Make sure your roof rack cross members are not in the way over the antenna. It needs to be clear of obstruction and have a clear view of the sky. I can't test that channel for you because mine is covered by my roof basket.
 

·
Registered
Joined
·
8 Posts
When I got my 2006, it was the same way. I read on here that for some reason or another these radios do not broadcast the channel (184). I had the life time subscription and it took a couple of hours after I called and had it transferred over before it works. No problems after that. I had to find on here how to get the radio number to do the transfer, the customerless service from Sirius didn't know how to get it and said there must be a problem with the radio. But thanks to the great resources here was able to get it working.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #7
Ch. 184 No Signal Error is common for open Sirius radio

When I got my 2006, it was the same way. I read on here that for some reason or another these radios do not broadcast the channel (184). I had the life time subscription and it took a couple of hours after I called and had it transferred over before it works. No problems after that. I had to find on here how to get the radio number to do the transfer, the customerless service from Sirius didn't know how to get it and said there must be a problem with the radio. But thanks to the great resources here was able to get it working.
Thank you all, it turned out this no signal error is common on other cars too. It simply turned out the account needed activation to energize.

The Sirius reps are wrong ,the radio was working. It just needed activation from Sirius just like many posters here stated.
 
1 - 7 of 7 Posts
Top