Jeep Commander Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I have an 07 Commander, no nav, with BA audio package. My entire right side of the vehicle has no sound about 90% of the time. I am no expert but was thinking there was a wiring issue since it was the entire side, not just one speaker.

I took it to the dealership and the tech told me just one speaker was out (?) and this was causing my problem. He said a new speaker would be 245 dollars and I was better off buying new, nicer speakers and that for 245 I could buy all 6 and have money leftover probably.

After doing some research I have found that most speakers are 4 ohm and the factory speakers were 2 ohm. I am not looking to change the head unit and want to keep this as cheap as possible, where can I find 2 ohm speakers?
 

·
Registered
Joined
·
554 Posts
I'd go with Mopar Kicker speakers. Thet're compatible with your head unit and are supposed to have better sound than the b a's
 

·
Registered
Joined
·
954 Posts

·
Registered
Joined
·
954 Posts
Thanks!!!!!!
No problem! Let us know if you replace them for those speakers and give us your overall thought on the sound quality. I'm interested to see how much better they sound over the BAs.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
I wanted to make sure it really was the speaker before swapping everything out so I switched the right dash speaker with the left (right wasnt working before) now the left is still working, the right is working but I can make it crackle and go in and out by moving it with my hand.

Thinking now its a wiring problem?
 

·
Registered
Joined
·
147 Posts
Yes because 1 bad speaker is not going to make 3 not work. That would be the case if they were wired in series but they wire speakers in parallel so they can use the radio to control the speakers individually with the fade and balance features.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
Yes because 1 bad speaker is not going to make 3 not work. That would be the case if they were wired in series but they wire speakers in parallel so they can use the radio to control the speakers individually with the fade and balance features.
The strange part is now the right side door and rear speaker are working...but that to me is more evidence of a wiring issue/short somewhere.

If the R dash wasnt working and I put it in the L dash and it works, then the problem isnt that speaker...
 
1 - 9 of 9 Posts
Top